summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2019-09-30 13:21:13 -0400
committerRichard Freeman <rich0@gentoo.org>2019-09-30 13:21:13 -0400
commitb5f7a2545ddee66cac3394e7b4bc1e3ae3f3aa55 (patch)
tree804d87d0690bab58df859f5de435dd765c220e11 /app-backup
parentsys-boot/palo: Stable (diff)
downloadgentoo-b5f7a2545ddee66cac3394e7b4bc1e3ae3f3aa55.tar.gz
gentoo-b5f7a2545ddee66cac3394e7b4bc1e3ae3f3aa55.tar.bz2
gentoo-b5f7a2545ddee66cac3394e7b4bc1e3ae3f3aa55.zip
app-backup/duplicity: bump, EAPI 7 port
Fixes: https://bugs.gentoo.org/672710 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.7.19.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index edb4b512a4d5..7f29959526f2 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -6,3 +6,4 @@ DIST duplicity-0.7.14.tar.gz 1556110 BLAKE2B 32d4d7f941a09e85915724352ec14d6ed1b
DIST duplicity-0.7.15.tar.gz 1563272 BLAKE2B 1a5487d863253298ecab0bf328bc7e4aa7ac7df4e2b2dd47fd60b674310bcb9046e96546860fb6f299cddeb3ad384abae615a065759798e7215addb064d4582b SHA512 7cdcf1c707e9bdbbc250afcd359978607454b1614128d2b7f09403867195795606794c5f193dc869579ae8c3a9251d7ef8f9acd66d4e69bce91344d7c046ca90
DIST duplicity-0.7.16.tar.gz 1563676 BLAKE2B 67e1a205a880b2658ed265efa46590553537881d82af21f538fe0b524338ed8450ded1dcc30089ecf13892f5cccc284fe2acd3dbb1a17597557640ccbb1376cd SHA512 552f63848ce90ccd8481136df6c0918bbf2463dde00d4e54f0af3693dc5439551ac086dc43b7b7191d1dcf0b710d7391b6c627ce0effd14a59beb0b5fa06a804
DIST duplicity-0.7.17.tar.gz 1719145 BLAKE2B fb5b3b3319305e63aaabcf4feef89d8a9c7b84d8e1ff09082cbfb49ebb7129a88afe6c85f6db892c0fdc8a27ca2b247e903e20a2f7b7fd9d6ced0aa77f15a2d4 SHA512 a7fa3f26709bcb25be519a20d65a196072a49ca468ace84b4876a815efea23fc1ed5b77abf765475fb8a08e3138349bf1d48e0ce22816ef66526463b646e12a3
+DIST duplicity-0.7.19.tar.gz 1727321 BLAKE2B 6441a2ce777b3b08c52ede8602a73080be372dec1c1788441c7e7135533aeeb3be48012db4bdfc2a78c7ca23d368637ccc7aa0f0361369ac9f42c00a1541e023 SHA512 26d1724a635c368e04f2a94f974ef6962c52b23345db59af3343e7221295caa0215ae119fff6ab44daa4622236683eb9d3dae742bf0d4cf08c02e3f63071001b
diff --git a/app-backup/duplicity/duplicity-0.7.19.ebuild b/app-backup/duplicity/duplicity-0.7.19.ebuild
new file mode 100644
index 000000000000..96eaf6101875
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}