summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-22 17:24:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-22 17:28:59 +0100
commitbcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c (patch)
treebf40d45865c5924944cfa9f697ecacaad6fc1b04 /app-backup
parentsys-process/fcron: rollover stable keywords (diff)
downloadgentoo-bcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c.tar.gz
gentoo-bcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c.tar.bz2
gentoo-bcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c.zip
app-backup/tarsnap: respect AR
Closes: https://bugs.gentoo.org/721914 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/tarsnap/files/tarsnap-1.0.39-respect-AR.patch14
-rw-r--r--app-backup/tarsnap/tarsnap-1.0.39.ebuild10
2 files changed, 22 insertions, 2 deletions
diff --git a/app-backup/tarsnap/files/tarsnap-1.0.39-respect-AR.patch b/app-backup/tarsnap/files/tarsnap-1.0.39-respect-AR.patch
new file mode 100644
index 000000000000..f5a1115f161d
--- /dev/null
+++ b/app-backup/tarsnap/files/tarsnap-1.0.39-respect-AR.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/721914
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -124,7 +124,7 @@ CONFIG_HEADER = config.h
+ CONFIG_CLEAN_FILES =
+ CONFIG_CLEAN_VPATH_FILES =
+ LIBRARIES = $(noinst_LIBRARIES)
+-AR = ar
++AR := ar
+ ARFLAGS = cru
+ AM_V_AR = $(am__v_AR_@AM_V@)
+ am__v_AR_ = $(am__v_AR_@AM_DEFAULT_V@)
+
diff --git a/app-backup/tarsnap/tarsnap-1.0.39.ebuild b/app-backup/tarsnap/tarsnap-1.0.39.ebuild
index 42bf7639963d..2d6ba5fde749 100644
--- a/app-backup/tarsnap/tarsnap-1.0.39.ebuild
+++ b/app-backup/tarsnap/tarsnap-1.0.39.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit bash-completion-r1
+inherit bash-completion-r1 toolchain-funcs
DESCRIPTION="Online backups for the truly paranoid"
HOMEPAGE="https://www.tarsnap.com/"
@@ -26,6 +26,8 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/os-headers" # Required for "magic.h"
+PATCHES=( "${FILESDIR}"/${PN}-1.0.39-respect-AR.patch )
+
S=${WORKDIR}/${PN}-autoconf-${PV}
src_configure() {
@@ -37,6 +39,10 @@ src_configure() {
$(use_with lzma)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
default
dobashcomp misc/bash_completion.d/*