summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-07-01 18:18:17 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-07-04 19:20:42 -0400
commitd444aec7d6cb100d05c72aa9d4e8718d60bb69ae (patch)
treef8dc92c63c8b778a17fa11e8963fe2db6504ba53 /app-backup
parentsci-visualization/yt: version bump. switch to sci-astronomy (diff)
downloadgentoo-d444aec7d6cb100d05c72aa9d4e8718d60bb69ae.tar.gz
gentoo-d444aec7d6cb100d05c72aa9d4e8718d60bb69ae.tar.bz2
gentoo-d444aec7d6cb100d05c72aa9d4e8718d60bb69ae.zip
app-backup/restic: bump to 0.7.0
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/restic-0.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 462499e05f1c..ae72245e3157 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,3 +1,4 @@
DIST restic-0.4.0.tar.gz 22926188 SHA256 746dbc7b73f5a542be57b71714b243266a011f1d750f56f5100c08a59df1aeac SHA512 ccd15f010f8da3bae3d33698e70ff1d9565f52fb56991b78d35f95493417a4ab050021153d81c424947233255d9553d050f7a66e1c709843fe3b2d323a81f85b WHIRLPOOL 94e6b9ed777a86cb6e46cf734b9280e68cc2ce1ea061c8a94409dca594add1ec24fb736a56e35571302ff5043a60bef7f60ff3b39b038ee128bc815f7d3d48cd
DIST restic-0.5.0.tar.gz 22937327 SHA256 a8e99087478a076b8a9c7c74d37cd23a56224d8c9b242c171756784ade024fda SHA512 571e4b0aa92a6cd9320f48c46a4b2190576d9328169d54762747dfa024ab280fb41ee377b59f0114d89ebd50bc54488a8cb5e2b36c57959202e848394107bb3c WHIRLPOOL 19fef25a6e2dff3145a6700abb581e7cae3abe5522ee0197f56a572d499824e84ba25a3111c5e71856ffac18d75622766c74c585a44b6db489468050e1c8d59a
DIST restic-0.6.1.tar.gz 25231223 SHA256 7cd709c592a5978723673397d7d13c37c0977e20c43db253d0c274b53a55654a SHA512 8c899ca8b6e3dfa399fe5c4306f72a1bcfa869dd667d27f3f88efa26aaa1000959bf91b515911b2ef7b2d4c5bb3e2ed4f202c87add7766d2147b7d40f0757a9a WHIRLPOOL 39225876fd6ce9e4ddac765688238ab5ea430272aacc6e96d54c359de939d2e69cdc45a5571cb63777c258a74b5a9bfbd6114d2463004b242b009856d87b6e2e
+DIST restic-0.7.0.tar.gz 25331189 SHA256 0d50e846429005fb78cb8d62876a8f0748942d7422cb115aba2d0669d25afee7 SHA512 13a7748d5317fb623b4a2dcc7771f09a2039159cc2a0d762d80ca253d59dd5d22f463fb2b033d134b540c2f239b9a75bb2eb13a08a61e009b78a56fa73ff4c2d WHIRLPOOL ae0d7fb17df4fd8346dcdd80172ec44e7127c354237472611e43a31bf85ed4342a6d79725761a7667608095e36d14b0e85a3b58bde27db24d0e5c9ff9c1b5027
diff --git a/app-backup/restic/restic-0.7.0.ebuild b/app-backup/restic/restic-0.7.0.ebuild
new file mode 100644
index 000000000000..03015bcb1464
--- /dev/null
+++ b/app-backup/restic/restic-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( README.rst CONTRIBUTING.md doc/design.rst doc/faq.rst doc/index.rst doc/manual.rst
+ doc/rest_backend.rst doc/development.rst doc/talks.rst doc/tutorial_aws_s3.rst doc/installation.rst )
+
+DEPEND="dev-lang/go
+ test? ( sys-fs/fuse )"
+
+RDEPEND="sys-fs/fuse"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-w -X main.version=${PV}"
+ -asmflags "-trimpath=${S}/vendor -trimpath=${S}"
+ -gcflags "-trimpath=${S}/vendor -trimpath=${S}"
+ -o "${S}"/restic cmds/restic
+ )
+
+ GOPATH="${S}:${S}/vendor" go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${S}:${S}/vendor" go test -v -work -x restic/... cmds/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+}