summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-01-05 11:41:21 -0500
committerCraig Andrews <candrews@gentoo.org>2021-01-05 11:43:29 -0500
commitdb0bc9f27dd1a0ca2888ea463519673e8de0a23a (patch)
tree6299c69eb98f504b27c8b2012209e01183e91819 /app-backup
parentpackage.mask: Last rite app-crypt/acme-client (diff)
downloadgentoo-db0bc9f27dd1a0ca2888ea463519673e8de0a23a.tar.gz
gentoo-db0bc9f27dd1a0ca2888ea463519673e8de0a23a.tar.bz2
gentoo-db0bc9f27dd1a0ca2888ea463519673e8de0a23a.zip
app-backup/btrbk: Fix race condition in install
Closes: https://bugs.gentoo.org/745808 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/btrbk/btrbk-0.30.0.ebuild6
-rw-r--r--app-backup/btrbk/files/btrbk-0.30.0-make-install-race.patch27
2 files changed, 32 insertions, 1 deletions
diff --git a/app-backup/btrbk/btrbk-0.30.0.ebuild b/app-backup/btrbk/btrbk-0.30.0.ebuild
index 11509324b00e..54cfb4dc81a1 100644
--- a/app-backup/btrbk/btrbk-0.30.0.ebuild
+++ b/app-backup/btrbk/btrbk-0.30.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,10 @@ RDEPEND="dev-lang/perl
mbuffer? ( >=sys-block/mbuffer-20180505 )
>=sys-fs/btrfs-progs-4.12"
+PATCHES=(
+ "${FILESDIR}/${P}-make-install-race.patch"
+)
+
src_compile() {
emake clean
use doc && emake -C doc
diff --git a/app-backup/btrbk/files/btrbk-0.30.0-make-install-race.patch b/app-backup/btrbk/files/btrbk-0.30.0-make-install-race.patch
new file mode 100644
index 000000000000..518e7df61185
--- /dev/null
+++ b/app-backup/btrbk/files/btrbk-0.30.0-make-install-race.patch
@@ -0,0 +1,27 @@
+https://github.com/digint/btrbk/pull/341
+
+From ec123405669762aefe813801e2c49183800cc3a9 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Mon, 28 Sep 2020 16:49:19 +0200
+Subject: [PATCH] Fix race condition in `make install`
+
+If run with -j, it's possible for install-bin-links to run before
+install-bin and subsequently fail because $(BINDIR) hasn't been created
+yet.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 030b577..44ab19f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -54,7 +54,7 @@ install-bin:
+ install -d -m 755 "$(DESTDIR)$(BINDIR)"
+ install -p -m 755 $(BIN) "$(DESTDIR)$(BINDIR)"
+
+-install-bin-links:
++install-bin-links: install-bin
+ @echo 'installing symlinks...'
+ for name in $(BIN_LINKS); do \
+ ln -s -n -f $(BIN) "$(DESTDIR)$(BINDIR)/$$name"; \