summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-04-23 14:39:30 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-04-23 14:51:09 -0400
commitf0a911b23d828a43facf26f1aafa97410c708761 (patch)
tree95dffc623bb0fff76c7dcff497a4c02d57a30438 /app-backup
parentnet-p2p/torrentinfo: add Python 3.8 support, fix dependencies (diff)
downloadgentoo-f0a911b23d828a43facf26f1aafa97410c708761.tar.gz
gentoo-f0a911b23d828a43facf26f1aafa97410c708761.tar.bz2
gentoo-f0a911b23d828a43facf26f1aafa97410c708761.zip
app-backup/borgbackup: remove older version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild b/app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild
deleted file mode 100644
index 822bb8bafab7..000000000000
--- a/app-backup/borgbackup/borgbackup-1.1.11-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- virtual/acl
- dev-python/llfuse[${PYTHON_USEDEP}]
- ~dev-python/msgpack-0.5.6[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-python_prepare_all() {
- rm -rf src/borg/algorithms/msgpack
- eapply "${FILESDIR}"/${P}-unbundle-msgpack.patch
- distutils-r1_python_prepare_all
-}
-
-src_install() {
- distutils-r1_src_install
- doman docs/man/*
-}