summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/bonnie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/bonnie')
-rw-r--r--app-benchmarks/bonnie/Manifest1
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6-r1.ebuild35
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6.ebuild35
-rw-r--r--app-benchmarks/bonnie/files/Makefile.patch17
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch13
-rw-r--r--app-benchmarks/bonnie/files/bonnie_man.patch16
-rw-r--r--app-benchmarks/bonnie/metadata.xml5
7 files changed, 122 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie/Manifest b/app-benchmarks/bonnie/Manifest
new file mode 100644
index 000000000000..1b0a4305d450
--- /dev/null
+++ b/app-benchmarks/bonnie/Manifest
@@ -0,0 +1 @@
+DIST bonnie.tar.gz 7140 SHA256 e420ca9275ddd9aa5fdb27d86851a57eea5ff94e8ccf6ba71352d35546842937 SHA512 4cb431986870baf1d9e5f757970a4b489f89d4349f051cc2ae0aea035ce19a7962047920a3af1567e375b2c6f1e826309b044b8a8727400601203042a34ecb5f WHIRLPOOL fee140ff6110edef099ae9d1b3bc50341730c4e53bef39db8a2b63451e8dcf12322e3b74c2537c3bebf86a230de5b75c6393dd915d13ba891363493331844876
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6-r1.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..909a18f708f0
--- /dev/null
+++ b/app-benchmarks/bonnie/bonnie-2.0.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
+HOMEPAGE="http://www.textuality.com/bonnie/"
+SRC_URI="http://www.textuality.com/bonnie/bonnie.tar.gz"
+
+LICENSE="bonnie"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/bonnie_man.patch \
+ "${FILESDIR}"/Makefile.patch \
+ "${FILESDIR}"/${P}-includes.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) SYSFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ newbin Bonnie bonnie
+ doman bonnie.1
+ dodoc Instructions
+}
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6.ebuild
new file mode 100644
index 000000000000..4cd7505bf0d7
--- /dev/null
+++ b/app-benchmarks/bonnie/bonnie-2.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
+HOMEPAGE="http://www.textuality.com/bonnie/"
+SRC_URI="http://www.textuality.com/bonnie/bonnie.tar.gz"
+
+LICENSE="bonnie"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A} || die
+ epatch "${FILESDIR}"/bonnie_man.patch
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_compile() {
+ make SYSFLAGS="${CFLAGS}" || die
+ mv Bonnie bonnie
+}
+
+src_install() {
+ doman bonnie.1
+ dodoc Instructions
+ dobin bonnie
+}
diff --git a/app-benchmarks/bonnie/files/Makefile.patch b/app-benchmarks/bonnie/files/Makefile.patch
new file mode 100644
index 000000000000..c4367087b8b5
--- /dev/null
+++ b/app-benchmarks/bonnie/files/Makefile.patch
@@ -0,0 +1,17 @@
+--- a/Makefile 1996-08-29 03:45:37.000000000 +0200
++++ b/Makefile 2011-08-25 16:07:10.757629898 +0200
+@@ -1,11 +1,11 @@
+-CFLAGS = -O $(SYSFLAGS)
++CFLAGS = $(SYSFLAGS)
+
+ bsd:
+ @echo 'Options are "make bsd" and "make SysV" - the default is "bsd".'
+ @echo 'If you get messages about missing functions, try "make SysV."'
+- make Bonnie
++ $(MAKE) Bonnie
+
+ SysV:
+- make Bonnie 'SYSFLAGS=-DSysV'
++ $(MAKE) Bonnie 'SYSFLAGS=-DSysV'
+
+ Bonnie:
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
new file mode 100644
index 000000000000..cfefe953c6f1
--- /dev/null
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
@@ -0,0 +1,13 @@
+--- a/Bonnie.c 1996-08-28 18:23:49.000000000 +0200
++++ b/Bonnie.c 2010-10-12 20:15:26.000000000 +0200
+@@ -29,6 +29,10 @@
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
++#include <time.h>
++#include <string.h>
++#include <stdlib.h>
++#include <sys/wait.h>
+ #if defined(SysV)
+ #include <limits.h>
+ #include <sys/times.h>
diff --git a/app-benchmarks/bonnie/files/bonnie_man.patch b/app-benchmarks/bonnie/files/bonnie_man.patch
new file mode 100644
index 000000000000..63dac33159a4
--- /dev/null
+++ b/app-benchmarks/bonnie/files/bonnie_man.patch
@@ -0,0 +1,16 @@
+--- bonnie.1.orig 2003-01-07 14:19:29.000000000 -0600
++++ bonnie.1 2003-01-07 14:20:19.000000000 -0600
+@@ -60,11 +60,11 @@
+ .fi
+ .in
+ ..
+-.TH Bonnie 1 "2.0.6" Textuality
++.TH bonnie 1 "2.0.6" Textuality
+ .SH NAME
+ Bonnie - File system benchmark
+ .SH "SYNOPSIS"
+-.B Bonnie
++.B bonnie
+ .RI "[-d\ scratch-dir]"
+ .RI "[-html]"
+ .RI "[-m\ machine-label]"
diff --git a/app-benchmarks/bonnie/metadata.xml b/app-benchmarks/bonnie/metadata.xml
new file mode 100644
index 000000000000..7e5a7f579109
--- /dev/null
+++ b/app-benchmarks/bonnie/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+</pkgmetadata>