summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-10-31 09:37:30 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2016-10-31 11:05:47 -0400
commitc090227bc0dc171fb4653fcd7b4396d22b4ac7d9 (patch)
tree0cea62d2e8e077dc803708ae49ebbf9870675a3c /app-benchmarks
parentdev-php/PEAR-Crypt_GPG: Version bump; (diff)
downloadgentoo-c090227bc0dc171fb4653fcd7b4396d22b4ac7d9.tar.gz
gentoo-c090227bc0dc171fb4653fcd7b4396d22b4ac7d9.tar.bz2
gentoo-c090227bc0dc171fb4653fcd7b4396d22b4ac7d9.zip
app-benchmarks/sysbench: improve live ebuild
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/sysbench/sysbench-9999.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/app-benchmarks/sysbench/sysbench-9999.ebuild b/app-benchmarks/sysbench/sysbench-9999.ebuild
index e82c950c0233..f6055be8c1da 100644
--- a/app-benchmarks/sysbench/sysbench-9999.ebuild
+++ b/app-benchmarks/sysbench/sysbench-9999.ebuild
@@ -12,14 +12,23 @@ HOMEPAGE="https://github.com/akopytov/sysbench"
EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
EGIT_BRANCH="1.0"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="aio mysql"
+IUSE="aio lua mysql postgres test"
-DEPEND="aio? ( dev-libs/libaio )
- mysql? ( virtual/libmysqlclient )"
-RDEPEND="${DEPEND}"
+RDEPEND="aio? ( dev-libs/libaio )
+ lua? ( dev-lang/lua:= )
+ mysql? ( virtual/libmysqlclient )
+ postgres? ( dev-db/postgresql:= )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool:=
+ dev-libs/libxslt
+ test? ( dev-util/cram )"
+
+REQUIRED_USE="
+ mysql? ( lua )
+ postgres? ( lua )"
src_prepare() {
default
@@ -32,15 +41,17 @@ src_prepare() {
src_configure() {
local myeconfargs=(
$(use_enable aio aio)
+ $(use_with lua lua)
$(use_with mysql mysql)
+ $(use_with postgres pgsql)
+ --without-attachsql
+ --without-drizzle
+ --without-oracle
)
econf "${myeconfargs[@]}"
}
-src_install() {
- default
-
- insinto /usr/share/${PN}/tests/db
- doins sysbench/tests/db/*.lua || die
+src_test() {
+ emake check test
}