summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/backlite/backlite-1.0.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/backlite/backlite-1.0.3-r1.ebuild')
-rw-r--r--app-cdr/backlite/backlite-1.0.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-cdr/backlite/backlite-1.0.3-r1.ebuild b/app-cdr/backlite/backlite-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..7120a7c3794d
--- /dev/null
+++ b/app-cdr/backlite/backlite-1.0.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="backlite is a pure QT4 version of k9copy"
+HOMEPAGE="http://k9copy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/k9copy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mplayer"
+
+# According to the author of backlite/k9copy libdvdread and libdvdnav are
+# bundled internal because newer versions produce bad DVD copies.
+# This will be fixed later.
+# DEPEND="media-libs/libdvdread"
+
+DEPEND=">=media-libs/libmpeg2-0.5.1
+ media-video/ffmpeg
+ dev-qt/qtgui:4
+ dev-qt/qtdbus:4
+ || ( dev-qt/qtphonon:4 media-libs/phonon[qt4] )"
+
+RDEPEND="${DEPEND}
+ media-video/dvdauthor
+ mplayer? ( media-video/mplayer )"
+
+src_prepare() {
+ sed -i -e '/^MimeTypes=.*/d' \
+ -e '/^Encoding=.*/d' *.desktop || die
+ epatch "${FILESDIR}/${P}-ffmpeg-0.11.patch" \
+ "${FILESDIR}/${P}-includepaths.patch" \
+ "${FILESDIR}/${P}-ffmpeg2.patch"
+}
+
+src_configure() {
+ eqmake4 backlite.pro PREFIX="${D}"/usr
+}
+
+src_install() {
+ unset INSTALL_ROOT
+ default
+}