summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-16 17:30:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-16 18:14:19 +0200
commit14f4e13acb238f31a18db354a6a7d4e17a641455 (patch)
tree9d37e439693254acf47c2cd45102e35a38a028e4 /app-cdr/cdemu-daemon
parentdev-libs/libmirage: Bump to 3.1.0 (diff)
downloadgentoo-14f4e13acb238f31a18db354a6a7d4e17a641455.tar.gz
gentoo-14f4e13acb238f31a18db354a6a7d4e17a641455.tar.bz2
gentoo-14f4e13acb238f31a18db354a6a7d4e17a641455.zip
app-cdr/cdemu-daemon: Bump to 3.1.0
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index ae99b7e9d6ad..8a8cc2f18aa8 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,2 +1,3 @@
DIST cdemu-daemon-3.0.2.tar.bz2 76029 SHA256 8c9a0d292e0fd71538f123f2b795f4490ff455f68b391b97812be369c34a4f06 SHA512 eb09880dcc984c8843cf0254d45aeaa39cff8faa3a415352c574b59ea6778de9bc10a9634022c1fe5c7de8aa0493129a7bd15b859a7ca3895d5175b2bb2296e1 WHIRLPOOL 918554fead811418bd1e1b1ad8cd22342c5e5559eb7e4f3e30f1ccb1c889547bbd7f70bd7af86c19af86a7c432281f3d98a2fb5d0ef59f57dcddf3ad0fc10686
DIST cdemu-daemon-3.0.4.tar.bz2 76121 SHA256 8101b4ad659de3cc53dcc39b14381d7d85b3dad131d780caefe9cc1c03551ecd SHA512 e5a3da9dd87e6ad6cf226e53628dbee76eb26104c51a511adb5b6b65d46e3f213a682ba0d845c8a651d939c44b853b6a9881e542e10f9f7d1dd579b8fc408154 WHIRLPOOL b92a78732f177e31b7a80288ec5253d92d5e92f796612cc288c7b976e46d5ebff3e8a2ffd9c3a0a1acb785893a0a663317ece75c3ed5c30592f69d53c01199b8
+DIST cdemu-daemon-3.1.0.tar.bz2 79943 SHA256 498f0f2fe2225de76acfe0b3dbf9606e4e2eb57ac9d29da9d48064b62587bc4f SHA512 f0f3de31b2bf6a97852bb1bc45d301e6cbf401ca7499f42e99811ca62431e86b344c83ddb4420571f2038e43432711e04817b9ed3859893eec7d36fbad8dfdb5 WHIRLPOOL 52768032e498607879ddecf96a6d5c909293488ec93c55aae7e9c0537e5b9d12567f6b3bc70c74fb65756a379bb7248954009c1f79ebd1e9090b36fe19b0ca80
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
new file mode 100644
index 000000000000..df8322759388
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}