summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/cdemu-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/cdemu-daemon')
-rw-r--r--app-cdr/cdemu-daemon/Manifest2
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-2.1.1.ebuild46
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.0.2.ebuild45
-rw-r--r--app-cdr/cdemu-daemon/metadata.xml11
4 files changed, 104 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
new file mode 100644
index 000000000000..8a91513c5ba7
--- /dev/null
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -0,0 +1,2 @@
+DIST cdemu-daemon-2.1.1.tar.bz2 62600 SHA256 d26782071184d555b06ad5def7d1c22916cbeb73377328879499b91e1196f36f SHA512 be59bf12e326855ccdfe5cec72a813b7a80dcc2cb408c3f19b9abe66eeb8d092e2755b1ba9f746ac7d3c1b27276ed857947ce1b2509d8cbf07eb1c6663f3536d WHIRLPOOL fd6ad9aa28ae9c821934099a3be271a1fe85db684dcc1ca9b65d499281ce65b27ac63d44c8570309d1fc3fbd486eadb165e15cec285c81bb07b10c709a1f6f42
+DIST cdemu-daemon-3.0.2.tar.bz2 76029 SHA256 8c9a0d292e0fd71538f123f2b795f4490ff455f68b391b97812be369c34a4f06 SHA512 eb09880dcc984c8843cf0254d45aeaa39cff8faa3a415352c574b59ea6778de9bc10a9634022c1fe5c7de8aa0493129a7bd15b859a7ca3895d5175b2bb2296e1 WHIRLPOOL 918554fead811418bd1e1b1ad8cd22342c5e5559eb7e4f3e30f1ccb1c889547bbd7f70bd7af86c19af86a7c432281f3d98a2fb5d0ef59f57dcddf3ad0fc10686
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-2.1.1.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-2.1.1.ebuild
new file mode 100644
index 000000000000..7b2e7b8faf2e
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-2.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/6" # subslot = CDEMU_DAEMON_INTERFACE_VERSION in CMakeLists.txt
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ <dev-libs/libmirage-3
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS README"
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.0.2.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.2.ebuild
new file mode 100644
index 000000000000..c31fa7c98c68
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS README"
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/metadata.xml b/app-cdr/cdemu-daemon/metadata.xml
new file mode 100644
index 000000000000..e56b6a0cf661
--- /dev/null
+++ b/app-cdr/cdemu-daemon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdemu</remote-id>
+ </upstream>
+</pkgmetadata>