summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild')
-rw-r--r--app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild b/app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild
new file mode 100644
index 000000000000..cf4294473c27
--- /dev/null
+++ b/app-cdr/dvdisaster/dvdisaster-0.72.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils gnome2-utils toolchain-funcs
+
+DESCRIPTION="Data-protection and recovery tool for DVDs"
+HOMEPAGE="http://dvdisaster.sourceforge.net/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug nls"
+
+dvdi_langs="cs de it pt_BR ru sv"
+for dvdi_lang in ${dvdi_langs}; do
+ IUSE+=" linguas_${dvdi_lang}"
+done
+unset dvdi_lang
+
+RDEPEND="app-arch/bzip2
+ >=dev-libs/glib-2.20
+ media-libs/libpng:0
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.14:2"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc \
+ --docsubdir=${PF} \
+ --localedir=/usr/share/locale \
+ --buildroot="${D}" \
+ --with-nls=$(usex nls) \
+ --with-memdebug=$(usex debug) || die
+}
+
+src_compile() {
+ emake $(use nls && echo -j1) CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install
+ dobin tools/pngpack
+
+ newdoc tools/README README.pngpack
+ dodoc CHANGELOG CREDITS.en README* TODO *HOWTO
+
+ newicon contrib/${PN}48.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN} 'System;Utility'
+
+ local res
+ for res in 16 32 48 64; do
+ newicon -s ${res} contrib/${PN}${res}.png ${PN}.png
+ done
+
+ local dest="${ED}"/usr/share
+
+ local dvdi_lang
+ for dvdi_lang in ${dvdi_langs}; do
+ use linguas_${dvdi_lang} || rm -rf \
+ ${dest}/doc/${PF}/${dvdi_lang} \
+ ${dest}/doc/${PF}/CREDITS.${dvdi_lang} \
+ ${dest}/man/${dvdi_lang}
+ done
+
+ rm -f "${ED}"/usr/bin/*-uninstall.sh
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }