summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/mp3burn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/mp3burn')
-rw-r--r--app-cdr/mp3burn/Manifest1
-rw-r--r--app-cdr/mp3burn/files/mp3burn-0.4.2-build.patch20
-rw-r--r--app-cdr/mp3burn/metadata.xml8
-rw-r--r--app-cdr/mp3burn/mp3burn-0.4.2.ebuild38
4 files changed, 67 insertions, 0 deletions
diff --git a/app-cdr/mp3burn/Manifest b/app-cdr/mp3burn/Manifest
new file mode 100644
index 000000000000..d36b750cc890
--- /dev/null
+++ b/app-cdr/mp3burn/Manifest
@@ -0,0 +1 @@
+DIST mp3burn-0.4.2.tar.gz 17166 SHA256 062f214dbd93636e0787cd2cff50344422b28ad56b399b11c0d7e737a245b901 SHA512 96234f7e7a528b0073e3cb8130d5f606741532954e54de56757b4b0945d24fa72860e62ae1d78a13463ed8dca22848d99d49791957ba3c92cb60591d0f54f261 WHIRLPOOL c9dcef27a4f2643c4698a8a41bc5066bbd463a2010663aa30aba8417edb5de486e4a3c659b74ed38888b2121916702c876e74ac57e726808d1812197d3ef553e
diff --git a/app-cdr/mp3burn/files/mp3burn-0.4.2-build.patch b/app-cdr/mp3burn/files/mp3burn-0.4.2-build.patch
new file mode 100644
index 000000000000..13cf94d42643
--- /dev/null
+++ b/app-cdr/mp3burn/files/mp3burn-0.4.2-build.patch
@@ -0,0 +1,20 @@
+--- mp3burn 2013-08-18 23:13:34.843372424 +0000
++++ mp3burn 2013-08-18 23:14:15.663182707 +0000
+@@ -412,6 +412,8 @@
+ => F<mp3decoder>. I<(Note: Currently, the MP3 decoder must be
+ able to accept mpg123-style command-line arguments.)>
+
++=back
++
+ =cut
+
+ $mp3decoder = $encoder if $encoder; # -M overrides .mp3burnrc
+@@ -586,6 +588,8 @@
+
+ =head1 DIAGNOSTICS
+
++=over 4
++
+ =item Error in .mp3burnrc:
+
+ Perl(1) cannot parse the F<.mp3burnrc> file.
diff --git a/app-cdr/mp3burn/metadata.xml b/app-cdr/mp3burn/metadata.xml
new file mode 100644
index 000000000000..ecaafbfb6544
--- /dev/null
+++ b/app-cdr/mp3burn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <upstream>
+ <remote-id type="sourceforge">mp3burn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-cdr/mp3burn/mp3burn-0.4.2.ebuild b/app-cdr/mp3burn/mp3burn-0.4.2.ebuild
new file mode 100644
index 000000000000..3a819f2322b4
--- /dev/null
+++ b/app-cdr/mp3burn/mp3burn-0.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Burn mp3s without filling up your disk with .wav files"
+HOMEPAGE="http://sourceforge.net/projects/mp3burn"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ media-sound/mpg123
+ media-libs/flac
+ media-sound/vorbis-tools
+ virtual/cdrtools
+ dev-perl/MP3-Info
+ dev-perl/ogg-vorbis-header
+ dev-perl/String-ShellQuote
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}