summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 11:21:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 14:22:37 +0200
commit733076242ec6d8241e03c0b0406b578ee4f80744 (patch)
treefeb740f13ad482ee5944891aa284452eef1dec2f /app-cdr
parentkde-apps/umbrello: 20.08.1 version bump (diff)
downloadgentoo-733076242ec6d8241e03c0b0406b578ee4f80744.tar.gz
gentoo-733076242ec6d8241e03c0b0406b578ee4f80744.tar.bz2
gentoo-733076242ec6d8241e03c0b0406b578ee4f80744.zip
app-cdr/dolphin-plugins-mountiso: 20.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.08.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index c1450a6707c0..9e5cff5bda96 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-20.08.0.tar.xz 227076 BLAKE2B 363636a0ad68b702e905cea14ca06311372b3fb647c57ea59375a859ad95d32cb2dbd851d209b991ffa143b85dcf1594cfd6493defa4886ebad6d201cf63d256 SHA512 4a9578bc9c20c9bcbb282369b7ac6955bdf1de20609762c2d0b396bd24a0a561422eda961f44761f59a2741db8b5191c8c6feb972d4a54a386ebb0fde67de5cb
+DIST dolphin-plugins-20.08.1.tar.xz 228072 BLAKE2B f6d0b0945eb1d9872ef20468e7e8df308d240909eda12bda00181f088c0ede3462f5b8560416500c1f199c1587a544cb65b41b5f89b89f2d493e57d077fc5b73 SHA512 e4f0a8899fd26055a80081236e4a9e14ea5d73c011ee0bf6cc934f599d24047adf86b16ff7164edcc59e101f11ad5364d9381f6852a11d6d36571366ff135e7b
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.08.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.08.1.ebuild
new file mode 100644
index 000000000000..b95d370e5ed2
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-20.08.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_RELEASE_SERVICE="true"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.72.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}