summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-01 21:06:56 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-01 21:06:56 +0100
commit79538c4d041a965c48546c224b21b9bd327a140d (patch)
tree650fb79d6964167986bfda3e730ff34aae1359cd /app-cdr
parentapp-antivirus/clamav: remove uclibc (diff)
downloadgentoo-79538c4d041a965c48546c224b21b9bd327a140d.tar.gz
gentoo-79538c4d041a965c48546c224b21b9bd327a140d.tar.bz2
gentoo-79538c4d041a965c48546c224b21b9bd327a140d.zip
app-cdr/cdrtools: remove uclibc
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdrtools/cdrtools-3.02_alpha09-r3.ebuild8
-rw-r--r--app-cdr/cdrtools/cdrtools-3.02_alpha09-r4.ebuild8
-rw-r--r--app-cdr/cdrtools/cdrtools-3.02_alpha09.ebuild8
-rw-r--r--app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch68
4 files changed, 3 insertions, 89 deletions
diff --git a/app-cdr/cdrtools/cdrtools-3.02_alpha09-r3.ebuild b/app-cdr/cdrtools/cdrtools-3.02_alpha09-r3.ebuild
index 124eaa59a097..3574e076027c 100644
--- a/app-cdr/cdrtools/cdrtools-3.02_alpha09-r3.ebuild
+++ b/app-cdr/cdrtools/cdrtools-3.02_alpha09-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,12 +51,6 @@ src_prepare() {
gnuconfig_update
- # This fixes a clash with clone() on uclibc. Upstream isn't
- # going to include this so let's try to carry it forward.
- # Contact me if it needs updating. Bug #486782.
- # Anthony G. Basile <blueness@gentoo.org>.
- use elibc_uclibc && eapply "${FILESDIR}"/${PN}-fix-clone-uclibc.patch
-
# Remove profiled make files.
find -name '*_p.mk' -delete || die "delete *_p.mk"
diff --git a/app-cdr/cdrtools/cdrtools-3.02_alpha09-r4.ebuild b/app-cdr/cdrtools/cdrtools-3.02_alpha09-r4.ebuild
index 34da04ffdca0..bb66090963d6 100644
--- a/app-cdr/cdrtools/cdrtools-3.02_alpha09-r4.ebuild
+++ b/app-cdr/cdrtools/cdrtools-3.02_alpha09-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,12 +51,6 @@ src_prepare() {
gnuconfig_update
- # This fixes a clash with clone() on uclibc. Upstream isn't
- # going to include this so let's try to carry it forward.
- # Contact me if it needs updating. Bug #486782.
- # Anthony G. Basile <blueness@gentoo.org>.
- use elibc_uclibc && eapply "${FILESDIR}"/${PN}-fix-clone-uclibc.patch
-
# Remove profiled make files.
find -name '*_p.mk' -delete || die "delete *_p.mk"
diff --git a/app-cdr/cdrtools/cdrtools-3.02_alpha09.ebuild b/app-cdr/cdrtools/cdrtools-3.02_alpha09.ebuild
index 7a64693f19ea..1a89a4a410a7 100644
--- a/app-cdr/cdrtools/cdrtools-3.02_alpha09.ebuild
+++ b/app-cdr/cdrtools/cdrtools-3.02_alpha09.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,12 +44,6 @@ src_prepare() {
gnuconfig_update
- # This fixes a clash with clone() on uclibc. Upstream isn't
- # going to include this so let's try to carry it forward.
- # Contact me if it needs updating. Bug #486782.
- # Anthony G. Basile <blueness@gentoo.org>.
- use elibc_uclibc && eapply "${FILESDIR}"/${PN}-fix-clone-uclibc.patch
-
# Remove profiled make files.
find -name '*_p.mk' -delete || die "delete *_p.mk"
diff --git a/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch b/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch
deleted file mode 100644
index 4ba244bf32b7..000000000000
--- a/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- a/readcd/readcd.c
-+++ b/readcd/readcd.c
-@@ -257,7 +257,7 @@
- BOOL pifscan;
- BOOL plot;
- BOOL fulltoc;
--BOOL clone;
-+BOOL clonetoc;
- BOOL edc_corr;
- BOOL noerror;
- BOOL nocorr;
-@@ -294,7 +294,7 @@
- error(_("\t-plot Print data suitable for gnuplot\n"));
- #ifdef CLONE_WRITE
- error(_("\t-fulltoc Retrieve the full TOC\n"));
-- error(_("\t-clone Retrieve the full TOC and all data\n"));
-+ error(_("\t-clonetoc Retrieve the full TOC and all data\n"));
- error(_("\t-edc-corr Try to do user level Reed Solomon repair (experimental)\n"));
- #endif
- error(_("\ttimeout=# set the default SCSI command timeout to #.\n"));
-@@ -320,7 +320,7 @@
- }
-
- /* CSTYLED */
--char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clone,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
-+char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clonetoc,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
-
- EXPORT int
- main(ac, av)
-@@ -397,7 +397,7 @@
- &scanbus, &dev, &scgopts, &sectors, &do_write,
- &c2scan, &cxscan, &pi8scan, &pifscan,
- &plot,
-- &fulltoc, &clone,
-+ &fulltoc, &clonetoc,
- &edc_corr,
- &noerror, &nocorr,
- &notrunc, &retries, &do_factor, &filename,
-@@ -679,7 +679,7 @@
-
- if (filename || sectors || c2scan || cxscan || pi8scan || pifscan ||
- meshpoints || fulltoc ||
-- clone || edc_corr) {
-+ clonetoc || edc_corr) {
- dorw(scgp, filename, sectors);
- } else {
- doit(scgp);
-@@ -894,9 +894,9 @@
- if (params.name == NULL)
- params.name = "/dev/null";
- read_ftoc(scgp, &params, FALSE);
-- } else if (clone || edc_corr) {
-+ } else if (clonetoc || edc_corr) {
- if (!is_mmc(scgp, NULL, NULL))
-- comerrno(EX_BAD, _("Unsupported device for clone mode.\n"));
-+ comerrno(EX_BAD, _("Unsupported device for clonetoc mode.\n"));
- if (!edc_corr)
- noerror = TRUE;
- if (retries == MAX_RETRY)
-@@ -904,7 +904,7 @@
- if (params.name == NULL)
- params.name = "/dev/null";
-
-- if (clone)
-+ if (clonetoc)
- if (read_ftoc(scgp, &params, TRUE) < 0)
- comerrno(EX_BAD, _("Read fulltoc problems.\n"));
- readcd_disk(scgp, &params);