summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 12:15:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 14:50:35 +0100
commit85595a0daf65f88b0b918f61477d82f4a6cae9e8 (patch)
tree592fc1ea1f53cb3bf5f72c7b583e63bd2ad7241f /app-cdr
parentkde-apps/umbrello: 21.12.1 version bump (diff)
downloadgentoo-85595a0daf65f88b0b918f61477d82f4a6cae9e8.tar.gz
gentoo-85595a0daf65f88b0b918f61477d82f4a6cae9e8.tar.bz2
gentoo-85595a0daf65f88b0b918f61477d82f4a6cae9e8.zip
app-cdr/dolphin-plugins-mountiso: 21.12.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.12.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index 59e3698db07f..c20ad1f6909f 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-21.08.3.tar.xz 254604 BLAKE2B 9a7a9c7a1cf82d458c1fd0bbce6b47c233b8a7a20bd1d1696bc75d6b04c8e4a9d6464025d8ad39b3bb96b8dd428fb880a5d318f7c0d13ef3bc8bf24a42c24169 SHA512 2fb7fbd6490d768f3eb7d756429d858337b8088a7c87836ed4a54fc3f863f50c4973bbe2ae149d53d2769d7ce3c31fbd737bc4afc74fd14260a158da83992076
DIST dolphin-plugins-21.12.0.tar.xz 254764 BLAKE2B 7c73390bd2c26643dfbc5593ef896ca674e5a0b17ede78e68504727125ac07370fb4b4139e0058e2050fbf065a7945f441ed7198fcd43fa9ea5fd679ba1998cb SHA512 c80f795dbb9a68a3d0f543a95386425289e9e2f8bd2c3bdf8644d05dd9ab651b8237528eee0535167448de165d7aac6f5f4bcc020d17d31d500a1958d7d0bcc2
+DIST dolphin-plugins-21.12.1.tar.xz 254672 BLAKE2B ab30e233774bd4d1bcd2446e19180235ba04248cf636f2c3dbe8b0e0c4a5756a35fbde78f429d2daf03cff969d47023395958305c94b3ab05e614f1e004347f8 SHA512 4fc0eb757cc32a881c0f764a09acc7aa1b8be302b8b74608121151a3ddb4cd3a2b299c0eb1fe5d7dcdf702cc331dd2bbda986bef079f9110a6fb0b9274ce397b
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.12.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.12.1.ebuild
new file mode 100644
index 000000000000..79a49e47e56a
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-21.12.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_GEAR="true"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.88.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}