summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 23:00:28 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-02 23:19:18 +0200
commitace87f9e81825c100b6a4dc1479bbd46db67dcab (patch)
treed38a9f9f3f208a9aa5a8cd8c0f75572f9079a43e /app-cdr
parentapp-office/libreoffice: Version bump to 5.1.4.2 (diff)
downloadgentoo-ace87f9e81825c100b6a4dc1479bbd46db67dcab.tar.gz
gentoo-ace87f9e81825c100b6a4dc1479bbd46db67dcab.tar.bz2
gentoo-ace87f9e81825c100b6a4dc1479bbd46db67dcab.zip
app-cdr/mirage2iso: Bump to EAPI 6, clean up
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/mirage2iso/mirage2iso-0.4.1-r1.ebuild (renamed from app-cdr/mirage2iso/mirage2iso-0.4.1.ebuild)14
-rw-r--r--app-cdr/mirage2iso/mirage2iso-9999.ebuild46
2 files changed, 21 insertions, 39 deletions
diff --git a/app-cdr/mirage2iso/mirage2iso-0.4.1.ebuild b/app-cdr/mirage2iso/mirage2iso-0.4.1-r1.ebuild
index 22b637fd1ebb..bc44d40c5e43 100644
--- a/app-cdr/mirage2iso/mirage2iso-0.4.1.ebuild
+++ b/app-cdr/mirage2iso/mirage2iso-0.4.1-r1.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit autotools-utils versionator
+EAPI=6
TESTS_PV=0.3
@@ -27,15 +25,17 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
pinentry? ( app-crypt/pinentry )"
+RESTRICT="!test? ( test )"
+
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_with pinentry libassuan)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}
src_test() {
mv "${WORKDIR}"/${PN}-${TESTS_PV}/tests/* tests/ || die
- autotools-utils_src_test
+ default
}
diff --git a/app-cdr/mirage2iso/mirage2iso-9999.ebuild b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
index 55d9c696e8a9..327133abc325 100644
--- a/app-cdr/mirage2iso/mirage2iso-9999.ebuild
+++ b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
@@ -1,60 +1,42 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils versionator
-
-TESTS_PV=0.3
+inherit autotools git-r3
DESCRIPTION="CD/DVD image converter using libmirage"
HOMEPAGE="https://bitbucket.org/mgorny/mirage2iso/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2
- test? ( https://www.bitbucket.org/mgorny/${PN}/downloads/${PN}-${TESTS_PV}-tests.tar.xz )"
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="pinentry test"
COMMON_DEPEND=">=dev-libs/libmirage-2.0.0:0=
dev-libs/glib:2=
pinentry? ( dev-libs/libassuan:0= )"
DEPEND="${COMMON_DEPEND}
+ dev-libs/libassuan
virtual/pkgconfig
test? ( app-arch/xz-utils )"
RDEPEND="${COMMON_DEPEND}
pinentry? ( app-crypt/pinentry )"
-#if LIVE
-DEPEND="${DEPEND}
- dev-libs/libassuan"
-KEYWORDS=
-SRC_URI=
-#endif
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_with pinentry libassuan)
)
- autotools-utils_src_configure
-}
-
-src_test() {
-#if LIVE
- autotools-utils_src_test
- return ${?}
-
-#endif
- mv "${WORKDIR}"/${PN}-${TESTS_PV}/tests/* tests/ || die
- autotools-utils_src_test
+ econf "${myconf[@]}"
}