summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-06 19:45:26 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-06 19:48:17 +0100
commitc9b663c6de96b2d326bdfe9afdbe04c7954806a0 (patch)
treec1a5dbf303dd3d8e266dbd4caea0ab33f7835615 /app-cdr
parentapp-i18n/man-pages-l10n: Version bump to 4.2.0 (diff)
downloadgentoo-c9b663c6de96b2d326bdfe9afdbe04c7954806a0.tar.gz
gentoo-c9b663c6de96b2d326bdfe9afdbe04c7954806a0.tar.bz2
gentoo-c9b663c6de96b2d326bdfe9afdbe04c7954806a0.zip
app-cdr/isomaster: Respect variable AR
Closes: https://bugs.gentoo.org/740138 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.15-ar.patch25
-rw-r--r--app-cdr/isomaster/isomaster-1.3.15.ebuild5
2 files changed, 28 insertions, 2 deletions
diff --git a/app-cdr/isomaster/files/isomaster-1.3.15-ar.patch b/app-cdr/isomaster/files/isomaster-1.3.15-ar.patch
new file mode 100644
index 000000000000..12c5ef4c3621
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.15-ar.patch
@@ -0,0 +1,25 @@
+From 1553ea30148f69bce545b3a79ab3f7847566c50a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 6 Feb 2021 19:36:33 +0100
+Subject: [PATCH] Makefile: Give external AR="$(tc-getAR)" a chance to win
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f005099..98808f8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -48,7 +48,7 @@ OPTFLAGS ?= -Wall
+
+ # programs used in the Makefiles:
+ export CC ?= gcc
+-export AR = ar
++export AR ?= ar
+ export RM = rm -f
+ export INSTALL = install
+ export CP = cp
+--
+2.30.0
+
diff --git a/app-cdr/isomaster/isomaster-1.3.15.ebuild b/app-cdr/isomaster/isomaster-1.3.15.ebuild
index 4409476a71a0..f9907cc82e04 100644
--- a/app-cdr/isomaster/isomaster-1.3.15.ebuild
+++ b/app-cdr/isomaster/isomaster-1.3.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-1.3.14-include-path.patch
+ "${FILESDIR}"/${PN}-1.3.15-ar.patch
)
pkg_setup() {
@@ -43,7 +44,7 @@ src_prepare() {
}
src_compile() {
- tc-export CC
+ tc-export AR CC
emake "${myisoconf[@]}"
}