summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-05 01:39:05 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-05 01:40:36 +0000
commitb05773a54f5ed6ebf7ff4b449976406fd807ca17 (patch)
tree85728d1264e2200cf699c0ff470bad080678eb91 /app-containers/apptainer
parentapp-containers/buildah: Remove vulnerable versions (diff)
downloadgentoo-b05773a54f5ed6ebf7ff4b449976406fd807ca17.tar.gz
gentoo-b05773a54f5ed6ebf7ff4b449976406fd807ca17.tar.bz2
gentoo-b05773a54f5ed6ebf7ff4b449976406fd807ca17.zip
app-containers/apptainer: add 1.0.0
This is a continuation of sys-cluster/singularity so keep the original keywords. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest1
-rw-r--r--app-containers/apptainer/apptainer-1.0.0.ebuild63
-rw-r--r--app-containers/apptainer/metadata.xml15
3 files changed, 79 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
new file mode 100644
index 000000000000..2a0979900d11
--- /dev/null
+++ b/app-containers/apptainer/Manifest
@@ -0,0 +1 @@
+DIST apptainer-1.0.0.tar.gz 11978144 BLAKE2B ca2444fedbd669e6da1a9bbc7c1561dfa8ddebcf82e14ce3233e7e4bbb743eb4b4289aeb1977afe4871ee3abc453ed61821fc25f5b28a0dbfe708253ec031fd9 SHA512 c772b9286d54b21112dba98b7361fac7e1661616643851dc12f58b2565a51d145806f8e5b5dc635b357526e5d270bea096498dcd6c40635530ec3beced6f582f
diff --git a/app-containers/apptainer/apptainer-1.0.0.ebuild b/app-containers/apptainer/apptainer-1.0.0.ebuild
new file mode 100644
index 000000000000..9f711a070ada
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.17.6
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/app-containers/apptainer/metadata.xml b/app-containers/apptainer/metadata.xml
new file mode 100644
index 000000000000..069f7e2cb731
--- /dev/null
+++ b/app-containers/apptainer/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <use>
+ <flag name="network">Install network plug-ins</flag>
+ <flag name="suid">Install SUID helper binary</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">apptainer/apptainer</remote-id>
+ </upstream>
+</pkgmetadata>