summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-02-04 10:22:42 -0800
committerZac Medico <zmedico@gentoo.org>2022-02-04 10:22:42 -0800
commit77bb29019583f38144e435bd8e3051a97e874a3b (patch)
tree667b39ead015f3fcab2fc5ff5294cf33d3297935 /app-containers/conmon
parentapp-containers/conmon: add libseccomp dependency (diff)
downloadgentoo-77bb29019583f38144e435bd8e3051a97e874a3b.tar.gz
gentoo-77bb29019583f38144e435bd8e3051a97e874a3b.tar.bz2
gentoo-77bb29019583f38144e435bd8e3051a97e874a3b.zip
app-containers/conmon: Bump to version 2.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/conmon')
-rw-r--r--app-containers/conmon/Manifest1
-rw-r--r--app-containers/conmon/conmon-2.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-containers/conmon/Manifest b/app-containers/conmon/Manifest
index c3866731eab9..9f788b077ab6 100644
--- a/app-containers/conmon/Manifest
+++ b/app-containers/conmon/Manifest
@@ -1,2 +1,3 @@
DIST conmon-2.0.30.tar.gz 161285 BLAKE2B c4e01759d819d3dff94b9ae09caa72b6f664e49d907d3a1be9fb4a0e1f782fad29a7cd7c89703e861f4aa6d7955996386f81460f19f22be2889c4f88c34536cb SHA512 2451e441913925f8423385b83e97630e980948a9bd57ae8800889016c4412a26bed598825d3c034c3edcecbab66c38417f55ad3866d3c2c98cada6acce2b2d16
DIST conmon-2.0.31.tar.gz 158184 BLAKE2B b14bae77a18cc352bc9583604544b4e7ffe4bd8a77e5c3185c897c11819bba227edcbd84b559d998a2b5648ca371f0e98e4d9cd15951a953cbe05a9c9ae9d434 SHA512 ff879fcd5a3b7de8ee6ff9de2a13d0afc36fdb392390278b26ee179be26ff375ddce4f5ae24e3e88b737f63202af64b49e82b2ffbfc0de8bfd14690dac523747
+DIST conmon-2.1.0.tar.gz 159045 BLAKE2B a39b7620091ca17f4d91a26e040f886293688562cba1827cc09c1da1c1401ad78cbb16420c9df8a055ab5ca3eb2933aec6ac1b9fbb1eea10f33b1b0d76c5dd54 SHA512 0f27a1b048c2dcafb40cd67f80c2a5d7e92f5beb849174233dc10e2db42b4ea8b89f27c901d3f38cf1d412ed875c5521e07140038e859fb54bcc554cb9197e74
diff --git a/app-containers/conmon/conmon-2.1.0.ebuild b/app-containers/conmon/conmon-2.1.0.ebuild
new file mode 100644
index 000000000000..ac41e5569b88
--- /dev/null
+++ b/app-containers/conmon/conmon-2.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ sys-libs/libseccomp
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}
+ dev-go/go-md2man"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+ sed -e 's|make -C tools|$(MAKE) -C tools|' -i Makefile || die
+ sed -e 's|^GOMD2MAN = .*|GOMD2MAN = go-md2man|' -i docs/Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake GIT_COMMIT="v${PV}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}