summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-02-09 12:16:37 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-02-09 12:19:33 -0600
commitea7d1e7d713094bf85dd7c98841654c5443d86cd (patch)
treef6657bb9b46869f6eaf7de2c845588eae50ac2e8 /app-containers/cosign
parentgnome-extra/gnome-commander: add a missing BDEPEND for 1.14.0 (diff)
downloadgentoo-ea7d1e7d713094bf85dd7c98841654c5443d86cd.tar.gz
gentoo-ea7d1e7d713094bf85dd7c98841654c5443d86cd.tar.bz2
gentoo-ea7d1e7d713094bf85dd7c98841654c5443d86cd.zip
app-containers/cosign: 1.5.1 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/cosign')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-1.5.1.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index fe32b136ec52..77538dee5d1e 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -1,2 +1,4 @@
DIST cosign-1.5.0-vendor.tar.xz 10089292 BLAKE2B 71e9fc37df524496cb1639b0ddefbb4e5595ffd088ae8a36976b8d1ff4d7bd17781bd267b02d3d5aff74c7682dde9c4a990c787a7e0a4e523664134aa36c0512 SHA512 9d867828d183a093335adb53fb6424d13149c8ce41c77906a42ef3bea171b265967fe6dcca2b2569967e5c3ce8c2752e3f5d2c4a104e2be196708d85b73f7784
DIST cosign-1.5.0.tar.gz 6595932 BLAKE2B dd4403ed71c6a3773cf5ff3adebeab197a0f2d2148da50d32ee6b4f3802ef2810fba500ba22aca65f7553f45caaf4d4044183925e77cad3dfe566e95b8272494 SHA512 fc7768e37bc7236d2275a51e4b3f0854051d018af62e25d7c20ac3d79f7deacde181b650752da9a859e24585915bbcaf2f1d34f73747f0ffe9871109e1a3e019
+DIST cosign-1.5.1-vendor.tar.xz 10098460 BLAKE2B cfb01a16e12638759ec0edfe58057fa405e4e281d0100e65bf11404967cd58296f3c522fd637a4a34b86a5d34209ba2177d5cc0e92f1aa020eda26615b856859 SHA512 b7fa85039d21501a20ce29732980db8b1b96aaeffccdb1158a2c3c3f8f6e9805991f25bb3e361dfce3b8daac8cce42b16b2a69a3d54efd3db99aafe49b6a81c1
+DIST cosign-1.5.1.tar.gz 6595482 BLAKE2B ce8056c3fa49a75e52b001693cc1c76dc152f7ddb1947d6862526e918e9dbbb7d934601ea00c3f47a747b748124846b68dbd4abbce5c332860cbbef52aae1be1 SHA512 6d46dd2ca59b0ad410d23c002727198bf94c35f6d15983b13a23216510efa555268cf31de84679ce6e9e9db7f82b51787cd923e7c263939d9eb7cabecaf9c428
diff --git a/app-containers/cosign/cosign-1.5.1.ebuild b/app-containers/cosign/cosign-1.5.1.ebuild
new file mode 100644
index 000000000000..dc1f1487587d
--- /dev/null
+++ b/app-containers/cosign/cosign-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-fix-makefile.patch
+)
+
+src_prepare() {
+ default
+ mv ../vendor . || die
+}
+
+src_compile() {
+ emake \
+ GIT_HASH=c3e4d8b7cd2f6f065941510b260f173b70c695fa \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+}