summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-25 04:03:22 +0000
committerSam James <sam@gentoo.org>2022-03-25 04:03:51 +0000
commit1de0ae5303425702cc8b7cbdaa6a26e52b95911b (patch)
tree2264509ff009d2cb2c4844241cca3b9c068fa29a /app-containers/crun
parentapp-containers/podman: prefer crun over runc (diff)
downloadgentoo-1de0ae5303425702cc8b7cbdaa6a26e52b95911b.tar.gz
gentoo-1de0ae5303425702cc8b7cbdaa6a26e52b95911b.tar.bz2
gentoo-1de0ae5303425702cc8b7cbdaa6a26e52b95911b.zip
app-containers/crun: add 1.4.4
Bug: https://bugs.gentoo.org/835976 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers/crun')
-rw-r--r--app-containers/crun/Manifest1
-rw-r--r--app-containers/crun/crun-1.4.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-containers/crun/Manifest b/app-containers/crun/Manifest
index 80ca148cff08..eba2b6fea90f 100644
--- a/app-containers/crun/Manifest
+++ b/app-containers/crun/Manifest
@@ -1,2 +1,3 @@
DIST crun-1.3.tar.gz 1889283 BLAKE2B d7e7f676ca5db8322b9da2110c9a9e8eb11b13b5e9f1432ccc6ef12bf6ae7db3a28e3227fac86091589a215394ec577e91ccbffec532dabf44be746cb8a5d404 SHA512 9600bdacf5fd2defa542230b6e134920eb80e9d4c49598167b9d58887719765c174f1ac8559c0092dc1b5435274124e0b29c3d0830df86d1cfd690d67c746016
DIST crun-1.4.2.tar.gz 1956517 BLAKE2B c5db3396902c33568c3f9a490c57f8781703018f228f07bb17b1ccaa5c2ab903eda76e50d46fa3be10e440e6a0c3f791744f05d7677c71e2510673077d0acbef SHA512 cc7b57ed945cb36a36cf2ceab57349f836a07164ef31e0cec8bbddc4451a5757e2a0b92bc553b8994a236d7869cfdf229a5dd5e5a0d7f139f8c2a8df5c151d3a
+DIST crun-1.4.4.tar.gz 1962130 BLAKE2B 59681ba7af5735b46d27b568b2f9c36b72dd20d33d1eda4c77284eaeb3a771746e5be26fac28284039f857a4853c3c8decbc9a83bb62004e4ae2da79f1470d31 SHA512 fe64f56bf0f1ed9fed4df4926dd57b0966863208726ad00d8b96dfb9440833f6f88c4223875a6b01fe350456bc2c1021d14efa32795762037e394737daa4bde7
diff --git a/app-containers/crun/crun-1.4.4.ebuild b/app-containers/crun/crun-1.4.4.ebuild
new file mode 100644
index 000000000000..23faad06c21f
--- /dev/null
+++ b/app-containers/crun/crun-1.4.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="+bpf +caps criu +seccomp systemd static-libs"
+
+DEPEND="
+ dev-libs/yajl:=
+ sys-kernel/linux-headers
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ # Need https://github.com/containers/libocispec/pull/107 to be merged & land in
+ # a crun release that syncs up w/ latest version, then can drop CONFIG_SHELL
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}