summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-27 14:37:35 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-27 14:37:41 -0500
commit8ded871a7511ef11bd28fab140940801ab935cee (patch)
treeeb16555f1e9289e18ebbf6062f4b82eb18659b79 /app-containers
parentsys-libs/glibc: 2.36 patchset bump (diff)
downloadgentoo-8ded871a7511ef11bd28fab140940801ab935cee.tar.gz
gentoo-8ded871a7511ef11bd28fab140940801ab935cee.tar.bz2
gentoo-8ded871a7511ef11bd28fab140940801ab935cee.zip
app-containers/syft: add 0.54.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.54.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index cbd6688e7aa2..ba8095a63085 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -2,3 +2,5 @@ DIST syft-0.52.0-deps.tar.xz 962322444 BLAKE2B 696dd14adf54c8ab51cc91d22028ce0ac
DIST syft-0.52.0.tar.gz 3726656 BLAKE2B de8492adde3bef944a9b853990ba5909aa14ccc223f42833fa2a49d1bd5772455bd3ab9ac3a8886b353dc79c6e93338e43e9c448623bd31c422155e0adb1f276 SHA512 2ffaaa154546061d1d61bf8f0b3d5cf10282dbbb08876cc9e87777a23efdba1fd462c395ee4cf14d334f49ae4575e2db5fe8b5fbe7439dd24ff22ec8efeb6501
DIST syft-0.53.4-deps.tar.xz 668995648 BLAKE2B a2120e677e1438ea8dc369939c157dcdff772bd98b1f32d6ac3edfb553cfc0f6dfde8dfe86f0b4306a4286dca08646e79f72c3cde8bcc86f7308dff6f22755fe SHA512 beaf914bcecf75d461e241aa3b96ac162dd8e5c1ffd69fa117ea6170b2f6f1c76a424e33e5a29cf177c0c5ac55b3399bae6cab564f055b80ba745dd28ebdef40
DIST syft-0.53.4.tar.gz 3765398 BLAKE2B 15abe368451c14dc0afa9c0d63cdd10d056c0b09f906478188c772241750e0d9e903bd0efe55d87c0c04c4a5a21fa5bc3e1e63b0115e2b24e068d0a52e68b560 SHA512 9267e45165b860540a89ad6c317351abe26d3089294ec9698fa26b37c4413581424f43aae3f01a111b68806c6de30e8464fce27eda1b1cba442e1e0f613843c5
+DIST syft-0.54.0-deps.tar.xz 667262532 BLAKE2B f81c3bb54be16c40f3ec811d42c307ef0bf917a06f9f2925b7cce4a1f595092d9efbb7cb20a98a0a0672ca95c257117b2f3da29849fdec453ea054552019cc24 SHA512 e774abcec8786c2c655aa2a369206c79911ea4c706c281c96fb82ec1482c500deb1058bd353a1b107f783eaa41532efdb7a7d50c14c873d612716dc9d8503c57
+DIST syft-0.54.0.tar.gz 3770999 BLAKE2B f33679764fc1904b08f9112a3bfa10f6b8e4ab16c3e1bde81283ad7feede92d9eccf04cd6734dbe11f2d838c0ed45f6a62006f5670eea7271428bae45d5ff55c SHA512 c92991c4c48e60101b55a163506abd89b36f6b80312f9ca3f9953027ba7145dd4f5c5e11c86ca328360991a875637528803e41dcfbba91b204a461de1109c445
diff --git a/app-containers/syft/syft-0.54.0.ebuild b/app-containers/syft/syft-0.54.0.ebuild
new file mode 100644
index 000000000000..266f7cc93850
--- /dev/null
+++ b/app-containers/syft/syft-0.54.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=21eb77206020c04c9ca5316562e32179c73926a9
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}