summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-22 13:49:17 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-22 13:49:23 -0700
commitc2320916136f52a9f3089f60b21ac3fd87a32ab7 (patch)
tree5064c85671b50d7edcf6f720c0e47d84926534b5 /app-containers
parentdev-python/ini2toml: Keyword 0.11-r1 mips, #861344 (diff)
downloadgentoo-c2320916136f52a9f3089f60b21ac3fd87a32ab7.tar.gz
gentoo-c2320916136f52a9f3089f60b21ac3fd87a32ab7.tar.bz2
gentoo-c2320916136f52a9f3089f60b21ac3fd87a32ab7.zip
app-containers/docker-registry: add 2.8.1
Bug: https://bugs.gentoo.org/872410 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-registry/Manifest1
-rw-r--r--app-containers/docker-registry/docker-registry-2.8.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-containers/docker-registry/Manifest b/app-containers/docker-registry/Manifest
index c13a696e584b..1c86f766db1e 100644
--- a/app-containers/docker-registry/Manifest
+++ b/app-containers/docker-registry/Manifest
@@ -1 +1,2 @@
DIST docker-registry-2.7.1.tar.gz 1996699 BLAKE2B 2e22db69f476be5a4688f5b3d6b41fbbf71460351543ae849f707dd5b3d56624f674815a25214002886b057f0859f75fd197bb275a7b3cc8a7787422f716ad0e SHA512 f6baf0e7aa96ebe828c628f7dfd84ee899331c3c1bdab86662aef595b092702b6d9b2c9be766a6de6d153ff4ca55d85c5fd8785a0968f285f56a32a50092c754
+DIST docker-registry-2.8.1.tar.gz 2007611 BLAKE2B abf3e630652f195cf3ad4d07e6d9845000e79d340b0bb8046528bb62592df754c125fd38a92d1af27d068fcd51910f80f356d6a894cb1b97f28d7042af24b898 SHA512 b9c8525051458ff4bf4592ca3ddba83c4325e88c6812ddb28c1567e331c1571f112e3b646ca970f0fe420f3b1d61d00f7151450d7b9948a08733606255731266
diff --git a/app-containers/docker-registry/docker-registry-2.8.1.ebuild b/app-containers/docker-registry/docker-registry-2.8.1.ebuild
new file mode 100644
index 000000000000..773fa15bb205
--- /dev/null
+++ b/app-containers/docker-registry/docker-registry-2.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot systemd
+
+EGIT_COMMIT="b5ca020cfbe998e5af3457fda087444cf5116496"
+EGO_PN="github.com/docker/distribution"
+
+DESCRIPTION="Docker Registry 2.0"
+HOMEPAGE="https://github.com/docker/distribution"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+
+DEPEND="
+ acct-group/registry
+ acct-user/registry
+"
+RDEPEND="${DEPEND}"
+
+SVCNAME="registry"
+
+src_prepare() {
+ default
+ pushd src/${EGO_PN} || die
+ eapply "${FILESDIR}"/${PN}-2.7.0-notification-metrics.patch
+ sed -e "s/git describe.*/echo ${PV})/" \
+ -e "s/git rev-parse.*/echo ${EGIT_COMMIT})/" \
+ -e "s/-s -w/-w/" \
+ -i Makefile || die
+ popd || die
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681072
+ GOPATH="${S}" GO_BUILD_FLAGS="-v" emake -C src/${EGO_PN} binaries
+}
+
+src_install() {
+ exeinto /usr/libexec/${PN}
+ doexe src/${EGO_PN}/bin/*
+ insinto /etc/docker/registry
+ newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
+ newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
+ newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
+ systemd_dounit "${FILESDIR}/${SVCNAME}.service"
+ keepdir /var/log/${SVCNAME}
+ fowners ${SVCNAME}:${SVCNAME} /var/log/${SVCNAME}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
+}