summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-08 10:04:06 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-08 10:05:02 +0200
commit21c34493ac2d95f44b79dd1afe8f07f10255faf0 (patch)
tree5c9d0843b37bb078965e8a913f67fbe51c4d7764 /app-crypt/acme-tiny
parentdev-ruby/bogus: enable ruby32 (diff)
downloadgentoo-21c34493ac2d95f44b79dd1afe8f07f10255faf0.tar.gz
gentoo-21c34493ac2d95f44b79dd1afe8f07f10255faf0.tar.bz2
gentoo-21c34493ac2d95f44b79dd1afe8f07f10255faf0.zip
app-crypt/acme-tiny: EAPI 7 -> 8, PEP517
Closes: https://bugs.gentoo.org/909867 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-crypt/acme-tiny')
-rw-r--r--app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild b/app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..41eb33d55d23
--- /dev/null
+++ b/app-crypt/acme-tiny/acme-tiny-5.0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python{3_9,3_10,3_11} )
+
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
+else
+ SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
+HOMEPAGE="https://github.com/diafygi/acme-tiny"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0"
+
+# Tests require a local ACME server to be set up.
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${PV} != 9999 ]]; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ fi
+}
+
+src_prepare() {
+ sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
+ einfo "The --account-email flag has been changed to --contact and"
+ einfo "has different syntax."
+ einfo "Please update your scripts accordingly"
+ fi
+ done
+}