summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-07-09 15:38:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-07-09 15:38:59 +0200
commitcdf555e8032b3a2cc0450b5978c4e1e91f9724a6 (patch)
treeb2b9bdfec0a7a9868140f2480cabe710ee04f0ea /app-crypt/acme/acme-0.8.1.ebuild
parentnet-print/cndrvcups-lb: correct 3.20 SRC_URI, fixup c505277. (diff)
downloadgentoo-cdf555e8032b3a2cc0450b5978c4e1e91f9724a6.tar.gz
gentoo-cdf555e8032b3a2cc0450b5978c4e1e91f9724a6.tar.bz2
gentoo-cdf555e8032b3a2cc0450b5978c4e1e91f9724a6.zip
app-crypt/acme: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/acme/acme-0.8.1.ebuild')
-rw-r--r--app-crypt/acme/acme-0.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-0.8.1.ebuild b/app-crypt/acme/acme-0.8.1.ebuild
new file mode 100644
index 000000000000..4d1249657b7e
--- /dev/null
+++ b/app-crypt/acme/acme-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> letsencrypt-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/ndg-httpsclient-0.4[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN} || die
+}