summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/aescrypt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/aescrypt/files')
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch62
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch40
2 files changed, 102 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
new file mode 100644
index 000000000000..8dac5b4e6f47
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
@@ -0,0 +1,62 @@
+From ab74ea544739ab044af1e9b398770d31add3b435 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:16:03 +0200
+Subject: [PATCH 1/2] build: respect CFLAGS, DESTDIR and permissions
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ Makefile | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ac661a8..abcdcc4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,8 @@ CC=gcc
+
+ #The below line is for debugging
+ #CFLAGS=-I. -ggdb -Wall -D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -D_FILE_OFFSET_BITS=64
++CFLAGS=-Wall
++EXTRA_CFLAGS=-D_FILE_OFFSET_BITS=64
+
+ LIBS=
+
+@@ -27,10 +28,10 @@ LIBS=
+ all: aescrypt aescrypt_keygen
+
+ aescrypt: aescrypt.o aes.o sha256.o password.o keyfile.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ aescrypt_keygen: aescrypt_keygen.o password.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ test:
+ @$(CC) -DTEST -o sha.test sha256.c
+@@ -48,15 +49,16 @@ testfile: aescrypt
+ cmp test.orig.txt test.txt
+
+ %.o: %.c %.h
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c $*.c
+
+ install: aescrypt
+- install -o root -g root -m 755 aescrypt /usr/bin
+- install -o root -g root -m 755 aescrypt_keygen /usr/bin
++ install -m 755 -d $(DESTDIR)/usr/bin
++ install -m 755 aescrypt $(DESTDIR)/usr/bin
++ install -m 755 aescrypt_keygen $(DESTDIR)/usr/bin
+
+ uninstall:
+- rm -f /usr/bin/aescrypt
+- rm -f /usr/bin/aescrypt_keygen
++ rm -f $(DESTDIR)/usr/bin/aescrypt
++ rm -f $(DESTDIR)/usr/bin/aescrypt_keygen
+
+ clean:
+ rm -f *.o aescrypt aescrypt_keygen test* *test
+--
+1.7.12.4
+
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
new file mode 100644
index 000000000000..616e87e38d61
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
@@ -0,0 +1,40 @@
+From 337cc9367a3cb4450eee245c6ceb615d0f05499d Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:18:08 +0200
+Subject: [PATCH 2/2] build: support disable iconv for static build
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ password.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/password.c b/password.c
+index 9a2c1f8..dee79da 100644
+--- a/password.c
++++ b/password.c
+@@ -232,6 +232,15 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ size_t ic_inbytesleft,
+ ic_outbytesleft;
+
++#ifdef DISABLE_ICONV
++ /* support only latin */
++ int i;
++ for (i=0;i<length+1;i++) {
++ out_passwd[i*2] = in_passwd[i];
++ out_passwd[i*2+1] = 0;
++ }
++ return length*2;
++#else
+ /* Max length is specified in character, but this function deals
+ * with bytes. So, multiply by two since we are going to create a
+ * UTF-16 string.
+@@ -273,5 +282,6 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ }
+ iconv_close(condesc);
+ return (max_length - ic_outbytesleft);
++#endif
+ }
+
+--
+1.7.12.4
+