summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-23 10:12:24 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-23 10:13:58 +0200
commit1c335fa8864d3d7f946fc62bda8a41b1b54688a7 (patch)
treedef87d505080627c9ac2d008b8fb228487e306bd /app-crypt/argon2
parentapp-crypt/argon2: Add myself as co-maint (diff)
downloadgentoo-1c335fa8864d3d7f946fc62bda8a41b1b54688a7.tar.gz
gentoo-1c335fa8864d3d7f946fc62bda8a41b1b54688a7.tar.bz2
gentoo-1c335fa8864d3d7f946fc62bda8a41b1b54688a7.zip
app-crypt/argon2: Bump to 20190702
Closes: https://bugs.gentoo.org/696184 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/argon2')
-rw-r--r--app-crypt/argon2/Manifest1
-rw-r--r--app-crypt/argon2/argon2-20190702.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/argon2/Manifest b/app-crypt/argon2/Manifest
index 0b6a21ebf666..2f970b45cb31 100644
--- a/app-crypt/argon2/Manifest
+++ b/app-crypt/argon2/Manifest
@@ -1 +1,2 @@
DIST argon2-20171227.tar.gz 1503745 BLAKE2B 70171ce1b446974e18e6f7077f436c6b78f29fd3eb075314014219280fd984e51b00137d901175da5fcb8a8472df0cbb16ff0333a2f2f098e52d3e0ea496e2cc SHA512 9c9e1a3905e61ac6913d1e073c104477e419ddd0506adc4487e88e98d19165ed8901fe8bb11246ed0cc71b3523c190da9692d5926642f86be09c3e67510afe4d
+DIST argon2-20190702.tar.gz 1505307 BLAKE2B fa9c3dde7b39c8d797a3d6b52992ebfe35f5eba1c7d7b3aa02c440edc36a3f5186cacee2e39e27ed7c6356dc1970dac0e8198d6f2065eb63ff77f9dfb2937cf8 SHA512 0a4cb89e8e63399f7df069e2862ccd05308b7652bf4ab74372842f66bcc60776399e0eaf979a7b7e31436b5e6913fe5b0a6949549d8c82ebd06e0629b106e85f
diff --git a/app-crypt/argon2/argon2-20190702.ebuild b/app-crypt/argon2/argon2-20190702.ebuild
new file mode 100644
index 000000000000..4f7b30a2b839
--- /dev/null
+++ b/app-crypt/argon2/argon2-20190702.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
+HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
+SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 CC0-1.0 )"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/phc-winner-${P}"
+
+DOCS=( argon2-specs.pdf CHANGELOG.md README.md )
+
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i -e '/LIBRARIES =/s/\$(LIB_ST)//' Makefile || die
+ fi
+ sed -i \
+ -e 's/-O3//' \
+ -e 's/-g//' \
+ -e 's/-march=\$(OPTTARGET)//' \
+ Makefile || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake OPTTEST=0 LIBRARY_REL="$(get_libdir)"
+}
+
+src_test() {
+ emake OPTTEST=0 test
+}
+
+src_install() {
+ emake OPTTEST=0 DESTDIR="${ED}" LIBRARY_REL="$(get_libdir)" install
+ einstalldocs
+ doman man/argon2.1
+}