summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild')
-rw-r--r--app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild b/app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild
new file mode 100644
index 000000000000..ad0824247af2
--- /dev/null
+++ b/app-crypt/bestcrypt/bestcrypt-2.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils linux-mod toolchain-funcs versionator
+
+MY_PN="bcrypt"
+MY_PV="$(replace_version_separator 2 -)"
+DESCRIPTION="commercially licensed transparent filesystem encryption"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BestCrypt-${MY_PV}.tar.gz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+pkg_setup() {
+ CONFIG_CHECK="MODULES"
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="bestcrypt(block::kernel/kmod)
+ bc_3des(crypto::kernel/kmod/crypto/algs/3des)
+ bc_bf128(crypto::kernel/kmod/crypto/algs/bf128)
+ bc_bf448(crypto::kernel/kmod/crypto/algs/bf448)
+ bc_blowfish(crypto::kernel/kmod/crypto/algs/blowfish)
+ bc_cast(crypto::kernel/kmod/crypto/algs/cast)
+ bc_des(crypto::kernel/kmod/crypto/algs/des)
+ bc_gost(crypto::kernel/kmod/crypto/algs/gost)
+ bc_idea(crypto::kernel/kmod/crypto/algs/idea)
+ bc_rijn(crypto::kernel/kmod/crypto/algs/rijn)"
+ BUILD_TARGETS="module"
+ BUILD_PARAMS=" \
+ KERNEL_DIR=\"${KV_DIR}\""
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ MAKEOPTS="-j1" linux-mod_src_compile
+ MAKEOPTS="-j1" emake \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ emake install PREFIX="${ED}" install
+
+ newinitd "${FILESDIR}/bcrypt3" bcrypt
+ sed -e '/\(bc_rc6\|bc_serpent\|bc_twofish\)/d' -i "${D}etc/init.d/bcrypt"
+ dodoc HIDDEN_PART README
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn
+
+ linux-mod_pkg_postinst
+}