summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-16 01:10:15 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-16 01:20:22 +0200
commitaa0c5d3b22c2eb9bb7ae42d9295babae823f91b5 (patch)
tree05a443f3f7283167364c88a5e5eaf2e2e2669c74 /app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
parentapp-crypt/certbot-dns-nsone: mark ALLARCHES (diff)
downloadgentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.tar.gz
gentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.tar.bz2
gentoo-aa0c5d3b22c2eb9bb7ae42d9295babae823f91b5.zip
app-crypt/certbot-dns-nsone: add 1.18.0, enable py3.10, tests and doc
Closes: https://bugs.gentoo.org/795543 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild')
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
new file mode 100644
index 000000000000..1fea8e6f659c
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S=${WORKDIR}/certbot-${PV}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest