summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-18 12:46:48 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-18 12:47:10 -0600
commit378de4fee5c9246ced848307675eb175283de813 (patch)
tree70fa833f3dd6e5528ee1f639ae11c0ac43c101ee /app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild
parentapp-crypt/certbot-apache: 0.21.0 bup (diff)
downloadgentoo-378de4fee5c9246ced848307675eb175283de813.tar.gz
gentoo-378de4fee5c9246ced848307675eb175283de813.tar.bz2
gentoo-378de4fee5c9246ced848307675eb175283de813.zip
app-crypt/certbot-nginx: 0.21.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild
new file mode 100644
index 000000000000..9e827c955370
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.21.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"