summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdward Hyunkoo Jee <edjee@google.com>2018-06-08 02:28:05 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-08 09:06:43 -0400
commit29f3f3ff28286ebb0c71a885769800a1155ea241 (patch)
tree5aab1e0624514dcc77de1bab67b6d2e57d4ed263 /app-crypt/efitools
parentx11-base/xorg-server: restore s390 keyword (diff)
downloadgentoo-29f3f3ff28286ebb0c71a885769800a1155ea241.tar.gz
gentoo-29f3f3ff28286ebb0c71a885769800a1155ea241.tar.bz2
gentoo-29f3f3ff28286ebb0c71a885769800a1155ea241.zip
app-crypt/efitools: fix dependency and use toolchain-funcs
This change fixes the issues addressed during the code review at https://github.com/gentoo/gentoo/pull/8648 . Fixes: ed1d845779b0 ("app-crypt/efitools: support "static" USE flag") Closes: https://github.com/gentoo/gentoo/pull/8755
Diffstat (limited to 'app-crypt/efitools')
-rw-r--r--app-crypt/efitools/efitools-1.8.1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-crypt/efitools/efitools-1.8.1.ebuild b/app-crypt/efitools/efitools-1.8.1.ebuild
index 0a1ca91df522..6ede95860eb5 100644
--- a/app-crypt/efitools/efitools-1.8.1.ebuild
+++ b/app-crypt/efitools/efitools-1.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git"
@@ -23,10 +23,7 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
DEPEND="${RDEPEND}
app-crypt/sbsigntool
dev-perl/File-Slurp
- static? (
- ${LIB_DEPEND}
- dev-util/pkgconfig
- )
+ static? ( ${LIB_DEPEND} )
sys-apps/help2man
sys-boot/gnu-efi
virtual/pkgconfig"
@@ -39,7 +36,8 @@ PATCHES=(
src_prepare() {
if use static; then
append-ldflags -static
- sed -i 's/-lcrypto/`pkg-config --static --libs libcrypto`/g' Makefile || die
+ sed -i "s/-lcrypto\b/$($(tc-getPKG_CONFIG) --static --libs libcrypto)/g" \
+ Makefile || die
fi
# Respect users CFLAGS