summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-11-23 21:20:15 +0100
committerAmy Liffey <amynka@gentoo.org>2018-11-23 21:38:05 +0100
commit7235361ed93100b1319b5cb83d1ab9dfae3ddf0e (patch)
tree474972837d1405de0cf3cdca5bbd7dba45c48ee1 /app-crypt/eid-mw/eid-mw-9999.ebuild
parentsys-apps/sysvinit: x86 stable (bug #671752) (diff)
downloadgentoo-7235361ed93100b1319b5cb83d1ab9dfae3ddf0e.tar.gz
gentoo-7235361ed93100b1319b5cb83d1ab9dfae3ddf0e.tar.bz2
gentoo-7235361ed93100b1319b5cb83d1ab9dfae3ddf0e.zip
app-crypt/eid-mw: version bump 4.4.11, adjust live ebuild
- Add p11v220 use flag (PKCS11 standard version 2.20) - Remove xpi obsolete useflag Submitted-by: Vincent Hardy <vincent.hardy.be@gmail.com> Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-crypt/eid-mw/eid-mw-9999.ebuild')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild48
1 files changed, 14 insertions, 34 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index 9c2c887e6186..4f93816f0b92 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -1,25 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools mozextension gnome2-utils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Fedict/${PN}.git"
- inherit git-r3
- SRC_URI=""
-else
- SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="~x86 ~amd64 ~arm"
-fi
+inherit autotools gnome2-utils git-r3
DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government"
HOMEPAGE="https://eid.belgium.be"
+EGIT_REPO_URI="https://github.com/Fedict/${PN}.git"
LICENSE="LGPL-3"
SLOT="0"
-IUSE="+dialogs +gtk p11-kit +xpi"
+IUSE="+dialogs +gtk +p11v220 p11-kit"
RDEPEND=">=sys-apps/pcsc-lite-1.2.9
gtk? (
@@ -30,9 +22,7 @@ RDEPEND=">=sys-apps/pcsc-lite-1.2.9
net-libs/libproxy
!app-misc/eid-viewer-bin
)
- p11-kit? ( app-crypt/p11-kit )
- xpi? ( || ( >=www-client/firefox-bin-3.6.24
- >=www-client/firefox-3.6.20 ) )"
+ p11-kit? ( app-crypt/p11-kit )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -45,6 +35,10 @@ src_prepare() {
sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
+ # legacy xpi module : we don't want it anymore
+ sed -i -e '/SUBDIRS/ s:plugins_tools/xpi ::' Makefile.am || die
+ sed -i -e '/plugins_tools\/xpi/ d' configure.ac || die
+
# hardcoded lsb_info
sed -i \
-e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \
@@ -58,33 +52,19 @@ src_prepare() {
src_configure() {
econf \
$(use_enable dialogs) \
+ $(use_enable p11v220) \
$(use_enable p11-kit p11kit) \
$(use_with gtk gtkvers 'detect') \
--with-gnu-ld \
- --disable-static \
- --disable-signed
+ --disable-static
}
src_install() {
default
-
- if use xpi; then
- declare MOZILLA_FIVE_HOME
- if has_version '>=www-client/firefox-3.6.20'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
- xpi_install "${ED}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
- fi
- if has_version '>=www-client/firefox-bin-3.6.24'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${ED}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
- fi
- else
- rm -r "${ED}"/usr/lib/mozilla || die
- fi
- rm -r "${ED}/usr/share/mozilla" "${ED}"/usr/$(get_libdir)/*.la || die
-
+ rm -r "${ED}"/usr/$(get_libdir)/*.la || die
if use gtk; then
- rm -r "${ED}/usr/include/eid-util" || die
+ domenu plugins_tools/eid-viewer/eid-viewer.desktop
+ doicon plugins_tools/eid-viewer/gtk/eid-viewer.png
fi
}