summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-23 11:30:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-23 11:30:50 +0200
commit8d2f337ba3e715471dc7b4efa7a1922221dfe79a (patch)
treeb1a7d554e3cd3658e7e471debbe041cbdee1df45 /app-crypt/gkeys/gkeys-0.2.ebuild
parentapp-admin/installer: Remove last-rited pkg (diff)
downloadgentoo-8d2f337ba3e715471dc7b4efa7a1922221dfe79a.tar.gz
gentoo-8d2f337ba3e715471dc7b4efa7a1922221dfe79a.tar.bz2
gentoo-8d2f337ba3e715471dc7b4efa7a1922221dfe79a.zip
app-crypt/gkeys: Remove last-rited pkg
Closes: https://bugs.gentoo.org/702430 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/gkeys/gkeys-0.2.ebuild')
-rw-r--r--app-crypt/gkeys/gkeys-0.2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-crypt/gkeys/gkeys-0.2.ebuild b/app-crypt/gkeys/gkeys-0.2.ebuild
deleted file mode 100644
index 3f6a31b7af09..000000000000
--- a/app-crypt/gkeys/gkeys-0.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=(python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="An OpenPGP/GPG key management tool for seed files and keyrings"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
-SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- app-crypt/gnupg
- >=dev-python/pyGPG-0.2[${PYTHON_USEDEP}]
- >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
- dev-python/snakeoil[${PYTHON_USEDEP}]
- >=app-crypt/gentoo-keys-201501052117
- "
-
-python_install_all() {
- distutils-r1_python_install_all
- keepdir /var/log/gkeys
- fperms g+w /var/log/gkeys
-}
-
-pkg_preinst() {
- chgrp users "${D}"/var/log/gkeys
-}
-
-pkg_postinst() {
- einfo "This is experimental software."
- einfo "The API's it installs should be considered unstable"
- einfo "and are subject to change."
- einfo
- einfo "This version includes a new gkeys-gpg command"
- einfo "It can be used as an alternate gpg command for git"
- einfo "It will set the correct keyring to verify signed commits"
- einfo "provided the key it needs to verify against is part of the gkeys"
- einfo "keyring system. It only works for verification, any other call "
- einfo "to it will re-direct directly to the normal gpg command."
- einfo
- einfo "Please file any enhancement requests, or bugs"
- einfo "at https://bugs.gentoo.org"
- einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
- einfo
- ewarn "There may be some Python 3 compatibility issues still."
- ewarn "Please help us debug, fix and report them in Bugzilla."
-}