summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-09-24 09:22:37 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-09-24 09:23:00 +0300
commit0824a358659678c52ada46bc9bb44af359586a96 (patch)
tree088df9080fba035fe00b2dba38ed11e15be1050f /app-crypt/gpgme
parentdev-ruby/seed-fu: add 2.3.6 (diff)
downloadgentoo-0824a358659678c52ada46bc9bb44af359586a96.tar.gz
gentoo-0824a358659678c52ada46bc9bb44af359586a96.tar.bz2
gentoo-0824a358659678c52ada46bc9bb44af359586a96.zip
app-crypt/gpgme: even simpler distutils usage
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/gpgme-1.7.0.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/app-crypt/gpgme/gpgme-1.7.0.ebuild b/app-crypt/gpgme/gpgme-1.7.0.ebuild
index 7ea80becd83d..2ffe8f38662b 100644
--- a/app-crypt/gpgme/gpgme-1.7.0.ebuild
+++ b/app-crypt/gpgme/gpgme-1.7.0.ebuild
@@ -45,7 +45,7 @@ PATCHES=(
do_python() {
if use python; then
pushd lang/python > /dev/null || die
- binary_builddir="${S}" distutils-r1_src_${EBUILD_PHASE}
+ distutils-r1_src_${EBUILD_PHASE}
popd > /dev/null
fi
}
@@ -71,20 +71,13 @@ src_configure() {
--enable-languages="${languages[*]}" \
$(use_enable static-libs static)
- python_conf() {
- econf --enable-languages=
- }
- use python && python_foreach_impl python_conf
+ use python && make -C lang/python prepare
+
do_python
}
src_compile() {
default
-
- python_build() {
- make -C lang/python prepare
- }
- use python && python_foreach_impl python_build
do_python
}