summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-01-07 20:10:39 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-01-07 20:10:55 +0200
commit0a4d9e09377bf103f34eb3ae945cd1e2d181df8b (patch)
tree126089207576f1c80d36940784f9393c99ed1e9a /app-crypt/gpgme
parentapp-text/texlive-core: bump poppler dep on versions having the poppler 0.60 fix. (diff)
downloadgentoo-0a4d9e09377bf103f34eb3ae945cd1e2d181df8b.tar.gz
gentoo-0a4d9e09377bf103f34eb3ae945cd1e2d181df8b.tar.bz2
gentoo-0a4d9e09377bf103f34eb3ae945cd1e2d181df8b.zip
app-crypt/gpgme: skip tests when WORKDIR is too long
Closes: https://bugs.gentoo.org/643696 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/gpgme-1.10.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-crypt/gpgme/gpgme-1.10.0.ebuild b/app-crypt/gpgme/gpgme-1.10.0.ebuild
index 110e0e94550b..ce5b9f1ca705 100644
--- a/app-crypt/gpgme/gpgme-1.10.0.ebuild
+++ b/app-crypt/gpgme/gpgme-1.10.0.ebuild
@@ -44,15 +44,14 @@ do_python() {
fi
}
-pkg_pretend() {
- local MAX_WORKDIR=66
-
- [[ "${#WORKDIR}" -le "${MAX_WORKDIR}" ]] ||
- die "Cannot build package as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail build"
-}
-
pkg_setup() {
addpredict /run/user/$(id -u)/gnupg
+
+ local MAX_WORKDIR=66
+ if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
+ ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
+ SKIP_TESTS=1
+ fi
}
src_prepare() {
@@ -76,6 +75,7 @@ src_configure() {
fi
econf \
+ $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
--enable-languages="${languages[*]}" \
$(use_enable static-libs static)
@@ -90,6 +90,8 @@ src_compile() {
}
src_test() {
+ [[ -z "${SKIP_TESTS}" ]] || return
+
default
if use python; then
test_python() {