summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-19 21:57:04 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-21 18:16:56 +0100
commitab5d09de85dc16fa34417cac6451100351d24fab (patch)
tree1220909c80f5d48fe6e37bbaac47a159a2b9f029 /app-crypt/gpgme
parentapp-crypt/gpgme: Block all kde-apps/gpgmepp SLOTs (diff)
downloadgentoo-ab5d09de85dc16fa34417cac6451100351d24fab.tar.gz
gentoo-ab5d09de85dc16fa34417cac6451100351d24fab.tar.bz2
gentoo-ab5d09de85dc16fa34417cac6451100351d24fab.zip
app-crypt/gpgme: Drop 1.8.0-r1
Closes: https://github.com/gentoo/gentoo/pull/3161 Package-Manager: portage-2.3.0 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/gpgme-1.8.0-r1.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/app-crypt/gpgme/gpgme-1.8.0-r1.ebuild b/app-crypt/gpgme/gpgme-1.8.0-r1.ebuild
deleted file mode 100644
index ef141d5de8d8..000000000000
--- a/app-crypt/gpgme/gpgme-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 eutils qmake-utils
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs cxx python qt5"
-
-COMMON_DEPEND="app-crypt/gnupg
- >=dev-libs/libassuan-2.0.2
- >=dev-libs/libgpg-error-1.11
- python? ( ${PYTHON_DEPS} )
- qt5? ( dev-qt/qtcore:5 )"
- #doc? ( app-doc/doxygen[dot] )
-DEPEND="${COMMON_DEPEND}
- python? ( dev-lang/swig )
- qt5? ( dev-qt/qttest:5 )"
-RDEPEND="${COMMON_DEPEND}
- cxx? (
- !kde-apps/gpgmepp:4
- !kde-apps/kdepimlibs:4
- )"
-
-REQUIRED_USE="qt5? ( cxx )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
- "${FILESDIR}"/${P}-cmake.patch
-)
-
-do_python() {
- if use python; then
- pushd lang/python > /dev/null || die
- distutils-r1_src_${EBUILD_PHASE}
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- default
- do_python
-}
-
-src_configure() {
- local languages=()
- use common-lisp && languages+=( "cl" )
- use cxx && languages+=( "cpp" )
- if use qt5; then
- languages+=( "qt" )
- #use doc ||
- export DOXYGEN=true
- export MOC="$(qt5_get_bindir)/moc"
- fi
-
- econf \
- --enable-languages="${languages[*]}" \
- $(use_enable static-libs static)
-
- use python && make -C lang/python prepare
-
- do_python
-}
-
-src_compile() {
- default
- do_python
-}
-
-src_install() {
- default
- do_python
- prune_libtool_files
-
- # backward compatibility for gentoo
- # in the past we had slots
- dodir /usr/include/gpgme
- dosym ../gpgme.h /usr/include/gpgme/gpgme.h
-}