summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/hashcat-gui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/hashcat-gui')
-rw-r--r--app-crypt/hashcat-gui/Manifest1
-rw-r--r--app-crypt/hashcat-gui/hashcat-gui-0.5.1.ebuild44
-rw-r--r--app-crypt/hashcat-gui/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/hashcat-gui/Manifest b/app-crypt/hashcat-gui/Manifest
new file mode 100644
index 000000000000..b4af8931cac5
--- /dev/null
+++ b/app-crypt/hashcat-gui/Manifest
@@ -0,0 +1 @@
+DIST hashcat-gui-0.5.1.zip 130106 SHA256 d8294724ce6ea5980ba98f43e44be6dd706c0bffc56128d2cd0db3c71aedd0d3 SHA512 c9162aa812c31713e3b7cf844d1d80c894db551b0e92483da0f02bc0f1a0a85e9ca17396f756caf0da1a1bf1bda1c77d97bdcc6758b6348567f1b39c4eb2f688 WHIRLPOOL 021369adcebc7bbcb99a9b3411ff046d14a62878ad83fe97aa1e3b1c49bf37c98645bc65206901a6af0de0efcebe350e988552b97bc4cd4c515d1b625a65496f
diff --git a/app-crypt/hashcat-gui/hashcat-gui-0.5.1.ebuild b/app-crypt/hashcat-gui/hashcat-gui-0.5.1.ebuild
new file mode 100644
index 000000000000..eb3709065450
--- /dev/null
+++ b/app-crypt/hashcat-gui/hashcat-gui-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A gui for the *hashcat* suite of tools"
+HOMEPAGE="https://github.com/scandium/hashcat-gui"
+
+SRC_URI="mirror://github/scandium/hashcat-gui/zipball/b6b01be723742ad89ba31fdb2c30b35306318f8b -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="cuda opencl"
+
+RDEPEND="app-crypt/hashcat-bin
+ cuda? ( app-crypt/oclhashcat-plus-bin
+ app-crypt/oclhashcat-lite-bin )
+ opencl? ( app-crypt/oclhashcat-plus-bin
+ app-crypt/oclhashcat-lite-bin )
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4"
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ app-arch/unzip"
+
+S="${WORKDIR}"/scandium-hashcat-gui-b6b01be/src
+
+src_prepare() {
+ sed -i 's#./hashcat#/opt/hashcat-bin#g' mainwindow.cpp || die
+ sed -i 's#./oclHashcat-plus#/opt/oclhashcat-plus-bin#g' mainwindow.cpp || die
+ sed -i 's#./oclHashcat-lite#/opt/oclhashcat-lite-bin#g' mainwindow.cpp || die
+}
+
+src_install() {
+ dobin hashcat-gui
+ cd "${WORKDIR}"/scandium-hashcat-gui-b6b01be || die
+ dodoc ChangeLog FAQ INSTALL README TODO
+}
diff --git a/app-crypt/hashcat-gui/metadata.xml b/app-crypt/hashcat-gui/metadata.xml
new file mode 100644
index 000000000000..0c85d8488350
--- /dev/null
+++ b/app-crypt/hashcat-gui/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <use>
+ <flag name="cuda">Install oclhashcat-{plus,lite}-bin to take advantage of hardware cuda support.</flag>
+ <flag name="opencl">Install oclhashcat-{plus,lite}-bin to take advantage of hardware opencl support.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">scandium/hashcat-gui</remote-id>
+ </upstream>
+</pkgmetadata>