summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-12-07 11:08:14 -0500
committerZero_Chaos <zerochaos@gentoo.org>2017-12-07 11:08:30 -0500
commitd8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead (patch)
treed3827c5ddfed2a55a9e09fb25ebff1e0cda88e61 /app-crypt/hashcat
parentapp-emulation/libvirt: Update apparmor profiles (diff)
downloadgentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.tar.gz
gentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.tar.bz2
gentoo-d8f8f5b6a2d8fb0cd0e452a9e259fd201a148ead.zip
app-crypt/hashcat: bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-crypt/hashcat')
-rw-r--r--app-crypt/hashcat/Manifest3
-rw-r--r--app-crypt/hashcat/hashcat-4.0.1.ebuild49
2 files changed, 51 insertions, 1 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
index ee84622ebb7a..e8d88d209187 100644
--- a/app-crypt/hashcat/Manifest
+++ b/app-crypt/hashcat/Manifest
@@ -1 +1,2 @@
-DIST hashcat-3.5.0.tar.gz 4103461 SHA256 af764698f48145ac96cf01c65cf76bcb88e205aeb4614025ae32d847571c4390 SHA512 7efc860461894a550fbacc406a40fec400232a120818180abba3d53f26bd3a503f58e7d189e4afad0f871c2244ff68371b145af58ab097478fe2d73f39c9a6b3 WHIRLPOOL 927ac7bfe902fcc9ead971f785f8231656335c1c190ffda1bb40b5affb8d7a3fb67d084102513a44e457a9d5ba1fba3969aa0e954669a33071fc65fba0b2424f
+DIST hashcat-3.5.0.tar.gz 4103461 BLAKE2B 821280182641ceadab7d712395a0a33cd7bfde8fcc8c133a2c12d089dc76b43edbee632f724083f29e9ec924991cda94e6f17b53f1b3155537d41286d3886832 SHA512 7efc860461894a550fbacc406a40fec400232a120818180abba3d53f26bd3a503f58e7d189e4afad0f871c2244ff68371b145af58ab097478fe2d73f39c9a6b3
+DIST hashcat-4.0.1.tar.gz 3905127 BLAKE2B 534270c7409f5a3dc4995a81fab63e6bfcd6b2bd4bb549f96b44e9c6bf24ce67505eb82803ace29fba69526c7c0703c66de9cc68cefcca79ef58040165041756 SHA512 7300b16ebd601fdbdbfd66adeba072c6f4f4dd5898dd85824513b97cc7848f4c2ae0fe523cfe7803fdba7954966ea289275fa5d49ff792706f73394e2bd95e77
diff --git a/app-crypt/hashcat/hashcat-4.0.1.ebuild b/app-crypt/hashcat/hashcat-4.0.1.ebuild
new file mode 100644
index 000000000000..d867ebec2e8e
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-4.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="custom-cflags video_cards_nvidia"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ #elif use vidia_cards_fglrx; then
+ # addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
+}