summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/keybase
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/keybase')
-rw-r--r--app-crypt/keybase/Manifest4
-rw-r--r--app-crypt/keybase/keybase-0.8.10.ebuild33
-rw-r--r--app-crypt/keybase/keybase-0.8.12.ebuild33
-rw-r--r--app-crypt/keybase/keybase-0.8.13.ebuild33
-rw-r--r--app-crypt/keybase/keybase-0.8.9.ebuild33
-rw-r--r--app-crypt/keybase/metadata.xml14
6 files changed, 150 insertions, 0 deletions
diff --git a/app-crypt/keybase/Manifest b/app-crypt/keybase/Manifest
new file mode 100644
index 000000000000..77681fbb3e8f
--- /dev/null
+++ b/app-crypt/keybase/Manifest
@@ -0,0 +1,4 @@
+DIST keybase-0.8.10.tar.gz 7055453 SHA256 ce9a22427d40341059071737ace2dacbe0a81e29e783ec2c8324e2704c1f558f SHA512 4701a0c8d88ffc90fa68f24ef4695f7c7b63ec91a41ccc1bf9d25efb182befc0750e1f9f5ec185161d65bdcbaeb3a73ab8f54f7047ab9d1efdca55b5f56957f0 WHIRLPOOL dd6d53154164ac235b89947530f7af4ed9fdc1421c26b2cef92e1721e2dcdf63e43fff054718c58c6a519f24f1766969a0e740f97d9eb17472d1ef8174e1851f
+DIST keybase-0.8.12.tar.gz 7057638 SHA256 fa6a8eb6f857d98d4d0f5c97862ba99480b0dd2c85fccd631180c0ab8f3ca97f SHA512 e8c568e0154308d3f0172a5e9b22de31c8a9b07d3a4f324a4afec57972602a3bd957220a96427eefa5df563ce0152495f5c33668536e03f3d6af9344c2061397 WHIRLPOOL e4a2431c05add26645f4ec3f2062a81d38c39ad9f9d6357f62009292f60fe072d67547d6c0a39470c130165bb9491fc7cb17cfe91a3fc1be75ad7a6377da9dad
+DIST keybase-0.8.13.tar.gz 7057750 SHA256 a485257b7302d848be41e9c0a79f7b1c0da4c8ceaee70c0cc011838cbd723fd8 SHA512 8a082ff9d61f960a0c4862fba04adf323005b3c70e6d208a38a001716bcc374e10cde315eced6730d90316466244e58a9de0f78a66ab2f9bd91326979f0ef28b WHIRLPOOL b651a48be0ced301991edd03d40182c0b900ea28e2b97630a3ad741b34266dbd95c3d370db636ca8088ce5e781a2cf609255a6b52a5b6bdbfa540b879cdcd778
+DIST keybase-0.8.9.tar.gz 7055307 SHA256 2feb54d26afc639f4d4998fbc35aafa2100a9926a6ec4f84343ca56d0284a3dd SHA512 431b3314cf939605a56f163b67226c9027a83159aae7f6b9226a4b5ccf63ecd3f79a873cbb9ab2756d83df2191823b70f884327f160187c00f6a6954b8ca144a WHIRLPOOL 4de64969a1e8898b19903cce391ca599af09b4f3dee6bf2b6bf10fcb39d8b6f939d5aa0320a5efe4b3aaf78217c6b6d7c16f09321af3ed115b6985194a0f0c0e
diff --git a/app-crypt/keybase/keybase-0.8.10.ebuild b/app-crypt/keybase/keybase-0.8.10.ebuild
new file mode 100644
index 000000000000..644ff738ea67
--- /dev/null
+++ b/app-crypt/keybase/keybase-0.8.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Client for keybase.io"
+HOMEPAGE="https://keybase.io/"
+SRC_URI="https://github.com/keybase/node-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/nodejs
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "node-client-${PV}" "${P}"
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md SIGNED.md
+ insinto "/opt/${PN}"
+ doins -r package.json bin certs json lib node_modules sql
+ dosym "${D}/opt/${PN}/bin/main.js" "${ROOT}/usr/bin/keybase"
+ chmod 0755 "${D}/opt/${PN}/bin/main.js" || die
+}
diff --git a/app-crypt/keybase/keybase-0.8.12.ebuild b/app-crypt/keybase/keybase-0.8.12.ebuild
new file mode 100644
index 000000000000..644ff738ea67
--- /dev/null
+++ b/app-crypt/keybase/keybase-0.8.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Client for keybase.io"
+HOMEPAGE="https://keybase.io/"
+SRC_URI="https://github.com/keybase/node-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/nodejs
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "node-client-${PV}" "${P}"
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md SIGNED.md
+ insinto "/opt/${PN}"
+ doins -r package.json bin certs json lib node_modules sql
+ dosym "${D}/opt/${PN}/bin/main.js" "${ROOT}/usr/bin/keybase"
+ chmod 0755 "${D}/opt/${PN}/bin/main.js" || die
+}
diff --git a/app-crypt/keybase/keybase-0.8.13.ebuild b/app-crypt/keybase/keybase-0.8.13.ebuild
new file mode 100644
index 000000000000..644ff738ea67
--- /dev/null
+++ b/app-crypt/keybase/keybase-0.8.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Client for keybase.io"
+HOMEPAGE="https://keybase.io/"
+SRC_URI="https://github.com/keybase/node-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/nodejs
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "node-client-${PV}" "${P}"
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md SIGNED.md
+ insinto "/opt/${PN}"
+ doins -r package.json bin certs json lib node_modules sql
+ dosym "${D}/opt/${PN}/bin/main.js" "${ROOT}/usr/bin/keybase"
+ chmod 0755 "${D}/opt/${PN}/bin/main.js" || die
+}
diff --git a/app-crypt/keybase/keybase-0.8.9.ebuild b/app-crypt/keybase/keybase-0.8.9.ebuild
new file mode 100644
index 000000000000..644ff738ea67
--- /dev/null
+++ b/app-crypt/keybase/keybase-0.8.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Client for keybase.io"
+HOMEPAGE="https://keybase.io/"
+SRC_URI="https://github.com/keybase/node-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/nodejs
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "node-client-${PV}" "${P}"
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md SIGNED.md
+ insinto "/opt/${PN}"
+ doins -r package.json bin certs json lib node_modules sql
+ dosym "${D}/opt/${PN}/bin/main.js" "${ROOT}/usr/bin/keybase"
+ chmod 0755 "${D}/opt/${PN}/bin/main.js" || die
+}
diff --git a/app-crypt/keybase/metadata.xml b/app-crypt/keybase/metadata.xml
new file mode 100644
index 000000000000..27b73883188c
--- /dev/null
+++ b/app-crypt/keybase/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ Get a public key, safely, starting just with someone's social media username(s)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keybase/node-client</remote-id>
+ </upstream>
+</pkgmetadata>