summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/libykneomgr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/libykneomgr')
-rw-r--r--app-crypt/libykneomgr/Manifest2
-rw-r--r--app-crypt/libykneomgr/libykneomgr-0.1.6.ebuild32
-rw-r--r--app-crypt/libykneomgr/libykneomgr-0.1.7.ebuild32
-rw-r--r--app-crypt/libykneomgr/metadata.xml12
4 files changed, 78 insertions, 0 deletions
diff --git a/app-crypt/libykneomgr/Manifest b/app-crypt/libykneomgr/Manifest
new file mode 100644
index 000000000000..847dd4fd8b90
--- /dev/null
+++ b/app-crypt/libykneomgr/Manifest
@@ -0,0 +1,2 @@
+DIST libykneomgr-0.1.6.tar.gz 633881 SHA256 7c0ddf2b5397e2d335da5d727c55d0be6a9ab43263c60edcac1ffe45b526ca95 SHA512 deb8deafa3c748bb888309d9d2d62f3657cd6d9d103ceee738abbc47a8e4466535e9641f104f5628657ec8924306b8d9d0a90cd2485dd5ad46dd2d8ee932fab4 WHIRLPOOL 3c9f1c53e411633b74b56eb991155a3ffbe2453a336b10b00a3e69a55f4c30b4df4ddfb50a7252ea058a76211d0683d029428bb24c839586b0277bde7297c582
+DIST libykneomgr-0.1.7.tar.gz 625509 SHA256 dcce20274976e29b63380633928e1e75e05544430fca37082465c9075ea29f5a SHA512 b97d0de0050a4dea55963403a8710fe94dbef05041ec4fc42c4f2e7fc7ebd64b94aeb8d8c0231ad7828840efff28e6bd5b392b25d6bcafbeaab469a6e52e5163 WHIRLPOOL 6af69069963859580fa03fd41e794d01895aaaefae3b87ae8a60575dfb82648eea5efb5970ac95608112969a174dbd75a7a2c8dade4c8ebffbed866ca6506fb6
diff --git a/app-crypt/libykneomgr/libykneomgr-0.1.6.ebuild b/app-crypt/libykneomgr/libykneomgr-0.1.6.ebuild
new file mode 100644
index 000000000000..644b5933cc40
--- /dev/null
+++ b/app-crypt/libykneomgr/libykneomgr-0.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev
+
+DESCRIPTION="YubiKey NEO CCID Manager C Library"
+HOMEPAGE="https://developers.yubico.com/libykneomgr/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux"
+
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/libzip"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.18[usb]"
+
+src_configure() {
+ local myeconfargs=(
+ --with-backend=pcsc
+ --disable-static
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/app-crypt/libykneomgr/libykneomgr-0.1.7.ebuild b/app-crypt/libykneomgr/libykneomgr-0.1.7.ebuild
new file mode 100644
index 000000000000..e6ffd1d0de4a
--- /dev/null
+++ b/app-crypt/libykneomgr/libykneomgr-0.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev
+
+DESCRIPTION="YubiKey NEO CCID Manager C Library"
+HOMEPAGE="https://developers.yubico.com/libykneomgr/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux"
+
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/libzip"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.18[usb]"
+
+src_configure() {
+ local myeconfargs=(
+ --with-backend=pcsc
+ --disable-static
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/app-crypt/libykneomgr/metadata.xml b/app-crypt/libykneomgr/metadata.xml
new file mode 100644
index 000000000000..415933a13d78
--- /dev/null
+++ b/app-crypt/libykneomgr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/libykneomgr</remote-id>
+ <bugs-to>https://github.com/Yubico/libykneomgr/issues</bugs-to>
+ </upstream>
+</pkgmetadata>