summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-10-22 10:53:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-04 01:16:15 +0100
commit4c4f34cebbaaa2570d966f1c32894428b2cebb47 (patch)
tree312471ba982d411f737e98e6fdf0f29ff8df221f /app-crypt/moolticute
parentapp-crypt/moolticute: HOMEPAGE: upstream moves into official org (diff)
downloadgentoo-4c4f34cebbaaa2570d966f1c32894428b2cebb47.tar.gz
gentoo-4c4f34cebbaaa2570d966f1c32894428b2cebb47.tar.bz2
gentoo-4c4f34cebbaaa2570d966f1c32894428b2cebb47.zip
app-crypt/moolticute: 0.10.0 version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-crypt/moolticute')
-rw-r--r--app-crypt/moolticute/Manifest3
-rw-r--r--app-crypt/moolticute/moolticute-0.10.0_beta.ebuild64
2 files changed, 66 insertions, 1 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 4d89ad9c7994..f27b1e1c4c42 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
-DIST moolticute-0.9.8_beta.tar.gz 4471922 SHA256 6d1524d104579c03901e1727c7eed3511fe74ce4dc538d846e69d28652129ddb SHA512 9b5829105172b9e461bfccf60de42aa0dc8529e319292006449f54f8590b3cf002c0e9b555b8ab379a6bfe6dad2e40ed142ea140e254337fa035f09e97e49465 WHIRLPOOL de95aed7084b974e370c14bafd989c4f07494fa5bccec64543bb944db73baf3cb0c5cb80bd7fc6314c38b3d30c661862aae72f19e098411f24db73710ffbf60b
+DIST moolticute-0.10.0_beta.tar.gz 4945663 BLAKE2B 371ab382239d635251b3921cbae24ee8f0ccefdd2ca2a102e73ecf2eccdef5a86f1613d9cc051871b37ebe9936ffb5f95719f7e3c36c4d7fdc58a18ba9948b73 SHA512 febb828cc179cbbc40684b7c382babfe998d8e14c59358d985658dabc0c414de7b5bec3187336459b286fb85b79f8d781254c7dc55ecd6519fc4ea50952af9b4
+DIST moolticute-0.9.8_beta.tar.gz 4471922 BLAKE2B 7914a9e949c2569e747a5a13b28a6db544bdfe0269ff002c41b86920381b76c1656569de99382cc5a4eaed89fafa0bf69209ed656625b1d8119f373cda7aa200 SHA512 9b5829105172b9e461bfccf60de42aa0dc8529e319292006449f54f8590b3cf002c0e9b555b8ab379a6bfe6dad2e40ed142ea140e254337fa035f09e97e49465
diff --git a/app-crypt/moolticute/moolticute-0.10.0_beta.ebuild b/app-crypt/moolticute/moolticute-0.10.0_beta.ebuild
new file mode 100644
index 000000000000..6176b1bb8674
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.10.0_beta.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}