summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/nasty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/nasty')
-rw-r--r--app-crypt/nasty/Manifest1
-rw-r--r--app-crypt/nasty/files/nasty-0.6-flags.patch22
-rw-r--r--app-crypt/nasty/metadata.xml8
-rw-r--r--app-crypt/nasty/nasty-0.6-r1.ebuild30
4 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/nasty/Manifest b/app-crypt/nasty/Manifest
new file mode 100644
index 000000000000..2cae4c193562
--- /dev/null
+++ b/app-crypt/nasty/Manifest
@@ -0,0 +1 @@
+DIST nasty-0.6.tgz 3811 SHA256 7607256d4672f1c52f2603d7b9691e7250bfe3a9b4f219fcbb61227172a7f6b7 SHA512 6803c1ccb843934ab6d2bd173c4cf154124926ee493a79072b351167f7fbbc08f90226ba63d2c591f2ae122d33d7cf1dc6b60e8684dc7ec650c8bcf3f04b3e07 WHIRLPOOL 77f03804ae4f3f8ea91f86cd70da2f63adc105cc50a985a667ec063066205fc388acb33a1464fc748901983ed6fd523b235c572906ff1fd7b7b43b7046e22bb9
diff --git a/app-crypt/nasty/files/nasty-0.6-flags.patch b/app-crypt/nasty/files/nasty-0.6-flags.patch
new file mode 100644
index 000000000000..271bbaab4984
--- /dev/null
+++ b/app-crypt/nasty/files/nasty-0.6-flags.patch
@@ -0,0 +1,22 @@
+--- Makefile
++++ Makefile
+@@ -1,15 +1,16 @@
+ VERSION=0.6
+
+ DEBUG=-g # -pg
+-CFLAGS+=-Wall -O2 -DVERSION=\"${VERSION}\" $(DEBUG)
+-LDFLAGS=-lgpgme $(DEBUG)
++CPPFLAGS+=-DVERSION=\"${VERSION}\" -D_FILE_OFFSET_BITS=64
++CFLAGS+=-Wall $(DEBUG) `gpgme-config --cflags`
++LIBS=`gpgme-config --libs`
+
+ OBJS=nasty.o
+
+ all: nasty
+
+ nasty: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o nasty
++ $(CC) $(LDFLAGS) $(OBJS) -o nasty $(LIBS)
+
+ install: nasty
+ cp nasty /usr/bin
diff --git a/app-crypt/nasty/metadata.xml b/app-crypt/nasty/metadata.xml
new file mode 100644
index 000000000000..f08d14f4a08f
--- /dev/null
+++ b/app-crypt/nasty/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-crypt/nasty/nasty-0.6-r1.ebuild b/app-crypt/nasty/nasty-0.6-r1.ebuild
new file mode 100644
index 000000000000..35c3375ccb50
--- /dev/null
+++ b/app-crypt/nasty/nasty-0.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
+HOMEPAGE="http://www.vanheusden.com/nasty/"
+SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-crypt/gpgme"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG= || die "emake failed"
+}
+
+src_install() {
+ dobin nasty || die "dobin nasty failed"
+ dodoc readme.txt
+}