summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/nistp224
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/nistp224')
-rw-r--r--app-crypt/nistp224/Manifest1
-rw-r--r--app-crypt/nistp224/files/nistp224-0.75-asmfix.patch39
-rw-r--r--app-crypt/nistp224/files/nistp224-0.75-declare-exit.patch18
-rw-r--r--app-crypt/nistp224/files/nistp224-0.75-honour-CC.patch79
-rw-r--r--app-crypt/nistp224/metadata.xml13
-rw-r--r--app-crypt/nistp224/nistp224-0.75-r1.ebuild57
6 files changed, 207 insertions, 0 deletions
diff --git a/app-crypt/nistp224/Manifest b/app-crypt/nistp224/Manifest
new file mode 100644
index 000000000000..b2e8dbc68fb3
--- /dev/null
+++ b/app-crypt/nistp224/Manifest
@@ -0,0 +1 @@
+DIST nistp224-0.75.tar.gz 204747 SHA256 4e033b1bd0bb906229ed8c42cf87aa03cdc54ad40593ca262c7178fe3425351d SHA512 1f15000e2d62b4a550599632949728b8c81cae61a91c28685c808263d363ef6985fda343ba982ea6ce48314bc4c245b3f099c5e05d2ebac81a0410f4960ffb88 WHIRLPOOL 6ff0b608d33e9c46c017e66346b1bc67ec011a316ee7620a497a8962b2466d3799d0fdcfbf255713395f692ce45497a6e208206154e224792a743df977953c3b
diff --git a/app-crypt/nistp224/files/nistp224-0.75-asmfix.patch b/app-crypt/nistp224/files/nistp224-0.75-asmfix.patch
new file mode 100644
index 000000000000..fd6bfa17109a
--- /dev/null
+++ b/app-crypt/nistp224/files/nistp224-0.75-asmfix.patch
@@ -0,0 +1,39 @@
+diff -ru math.orig/nistp224-0.75/src/opt-idea64.c math/nistp224-0.75/src/opt-idea64.c
+--- math.orig/nistp224-0.75/src/opt-idea64.c 2001-10-19 06:39:19.000000000 +1000
++++ math/nistp224-0.75/src/opt-idea64.c 2007-01-30 11:30:08.000000000 +1100
+@@ -2,7 +2,8 @@
+
+ static void fpmode(void)
+ {
+- asm volatile("fldcw %0"::"m"(0x137f));
++ static short int x=0x137f;
++ asm volatile("fldcw %0"::"m"(*&x));
+ }
+
+ #define T0 1.0
+diff -ru math.orig/nistp224-0.75/src/opt-pentium.c math/nistp224-0.75/src/opt-pentium.c
+--- math.orig/nistp224-0.75/src/opt-pentium.c 2001-10-19 06:39:19.000000000 +1000
++++ math/nistp224-0.75/src/opt-pentium.c 2007-01-30 11:30:44.000000000 +1100
+@@ -129,7 +129,8 @@
+
+ static inline void fpmode(void)
+ {
+- asm volatile("fldcw %0"::"m"(0x137f));
++ static short int x=0x137f;
++ asm volatile("fldcw %0"::"m"(*&x));
+ }
+
+ static void p_sqrt(double out[8],const double in[8])
+diff -ru math.orig/nistp224-0.75/src/opt-ppro.c math/nistp224-0.75/src/opt-ppro.c
+--- math.orig/nistp224-0.75/src/opt-ppro.c 2001-10-19 06:39:19.000000000 +1000
++++ math/nistp224-0.75/src/opt-ppro.c 2007-01-30 11:30:27.000000000 +1100
+@@ -120,7 +120,8 @@
+
+ static inline void fpmode(void)
+ {
+- asm volatile("fldcw %0"::"m"(0x137f));
++ static short int x=0x137f;
++ asm volatile("fldcw %0"::"m"(*&x));
+ }
+
+ static void p_sqrt(double out[8],const double in[8])
diff --git a/app-crypt/nistp224/files/nistp224-0.75-declare-exit.patch b/app-crypt/nistp224/files/nistp224-0.75-declare-exit.patch
new file mode 100644
index 000000000000..a1ecb432a022
--- /dev/null
+++ b/app-crypt/nistp224/files/nistp224-0.75-declare-exit.patch
@@ -0,0 +1,18 @@
+diff -Naur nistp224-0.75.orig/src/main.c nistp224-0.75/src/main.c
+--- math.orig/nistp224-0.75/src/main.c 2008-01-26 21:56:34.000000000 +0100
++++ math/nistp224-0.75/src/main.c 2008-01-26 22:05:17.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "nistp224.h"
+
+ unsigned char e[28];
+diff -Naur nistp224-0.75.orig/src/nistp224-56.c nistp224-0.75/src/nistp224-56.c
+--- math.orig/nistp224-0.75/src/nistp224-56.c 2008-01-26 21:56:34.000000000 +0100
++++ math/nistp224-0.75/src/nistp224-56.c 2008-01-26 21:57:10.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "nistp224.h"
+
+ unsigned char e[28];
diff --git a/app-crypt/nistp224/files/nistp224-0.75-honour-CC.patch b/app-crypt/nistp224/files/nistp224-0.75-honour-CC.patch
new file mode 100644
index 000000000000..1f5a938c2cc3
--- /dev/null
+++ b/app-crypt/nistp224/files/nistp224-0.75-honour-CC.patch
@@ -0,0 +1,79 @@
+--- Makefile.orig 2008-11-04 22:36:26.000000000 +0100
++++ Makefile 2008-11-04 22:40:08.000000000 +0100
+@@ -1,3 +1,5 @@
++CC=`head -n 1 conf-cc`
++
+ default: it
+
+ clean:
+@@ -108,7 +110,7 @@
+ hasrpcc.h load rts rts.exp speed systype
+ rm -f sysdeps
+ echo nistp224 0.75 >> sysdeps
+- gcc --version >> sysdeps
++ ${CC} --version >> sysdeps
+ cat systype compile load >> sysdeps
+ grep sysdep hasgethr.h >> sysdeps
+ grep sysdep hasrdtsc.h >> sysdeps
+--- find-systype.sh.orig 2008-11-04 22:35:18.000000000 +0100
++++ find-systype.sh 2008-11-04 22:36:51.000000000 +0100
+@@ -79,8 +79,8 @@
+ ;;
+ esac
+ else
+- gcc -c trycpp.c
+- gcc -o trycpp trycpp.o
++ ${CC} -c trycpp.c
++ ${CC} -o trycpp trycpp.o
+ case `./trycpp` in
+ nextstep)
+ oper="nextstep-`hostinfo | sed -n 's/^[ ]*NeXT Mach \([^:]*\):.*$/\1/p'`"
+--- print-cc.sh.orig 2008-11-04 22:34:51.000000000 +0100
++++ print-cc.sh 2008-11-04 22:35:04.000000000 +0100
+@@ -1,46 +1,5 @@
+ cc="`head -n 1 conf-cc`"
+ systype="`cat systype`"
+
+-
+-gcc -c trycpp.c -malign-double >/dev/null 2>&1 \
+-&& gccad="-malign-double"
+-
+-gcc -c trycpp.c -mcpu=ultrasparc >/dev/null 2>&1 \
+-&& gccus="-mcpu=ultrasparc"
+-
+-gcc -c trycpp.c -mcpu=powerpc >/dev/null 2>&1 \
+-&& gccpp="-mcpu=powerpc"
+-
+-gcc -c trycpp.c -mcpu=21164 >/dev/null 2>&1 \
+-&& gcc21="-mcpu=21164"
+-
+-rm -f trycpp.o
+-
+-
+-gccbase="gcc -fomit-frame-pointer -Wimplicit -Wunused -Wcomment -Wchar-subscripts -Wuninitialized -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings"
+-
+-
+-case "$cc:$systype" in
+- auto:*:i386-*:*)
+- cc="$gccbase -O1 $gccad"
+- ;;
+- auto:*:sparc-*:*:*:*)
+- cc="$gccbase -O1 $gccus"
+- ;;
+- auto:*:ppc-*:*:*:*)
+- cc="$gccbase -O2 $gccpp"
+- ;;
+- auto:*:alpha-*:*:*:*)
+- cc="$gccbase -O2 $gcc21"
+- ;;
+- auto:aix-*:-:-:*:-)
+- cc="$gccbase -O2 $gccpp"
+- ;;
+- auto:*)
+- cc="$gccbase -O2"
+- ;;
+-esac
+-
+-
+ cat warn-auto.sh
+ echo exec "$cc" '-c ${1+"$@"}'
diff --git a/app-crypt/nistp224/metadata.xml b/app-crypt/nistp224/metadata.xml
new file mode 100644
index 000000000000..8252e95f836a
--- /dev/null
+++ b/app-crypt/nistp224/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+nistp224 performs compressed Diffie-Hellman key exchange on the NIST P-224
+elliptic curve at record-setting speeds. It includes an easy-to-use C library
+and a command-line tool. nistp224 also supports uncompressed Diffie-Hellman key
+exchange on the same curve, with 56-byte public keys, at slightly higher speeds.
+</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/nistp224/nistp224-0.75-r1.ebuild b/app-crypt/nistp224/nistp224-0.75-r1.ebuild
new file mode 100644
index 000000000000..81d2ed987811
--- /dev/null
+++ b/app-crypt/nistp224/nistp224-0.75-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic fixheadtails
+
+DESCRIPTION="nistp224 performs compressed Diffie-Hellman key exchange on the NIST P-224 elliptic curve"
+HOMEPAGE="http://cr.yp.to/nistp224.html"
+SRC_URI="http://cr.yp.to/${PN}/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND=""
+RDEPEND=${DEPEND}
+S="${WORKDIR}/math/${P}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asmfix.patch
+ epatch "${FILESDIR}"/${P}-declare-exit.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-honour-CC.patch
+ ht_fix_file Makefile print*.sh
+}
+
+src_configure() {
+ append-flags -fPIC
+ echo -n "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo -n "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ if use ppc; then
+ # untested
+ echo -n "powerpc" > conf-opt
+ elif use sparc; then
+ # untested
+ echo -n "sparc" > conf-opt
+ else
+ # optiminations for ppro and pentium fail
+ echo -n "idea64" > conf-opt
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin nistp224 nistp224-56
+ mv nistp224.a libnistp224.a
+ dolib.a libnistp224.a
+ insinto /usr/include
+ doins nistp224.h
+}