summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-crypt/ophcrack
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/ophcrack')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.6.0.ebuild4
-rw-r--r--app-crypt/ophcrack/ophcrack-3.7.0.ebuild4
-rw-r--r--app-crypt/ophcrack/ophcrack-3.8.0.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
index 1e5b264f0c76..94d9250666bc 100644
--- a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
@@ -30,9 +30,9 @@ src_configure() {
myconf="${myconf} $(use_enable debug) --disable-gui"
- econf ${myconf} || die "Failed to compile"
+ econf ${myconf}
}
src_install() {
- emake install DESTDIR="${D}" || die "Installation failed."
+ emake install DESTDIR="${D}"
}
diff --git a/app-crypt/ophcrack/ophcrack-3.7.0.ebuild b/app-crypt/ophcrack/ophcrack-3.7.0.ebuild
index 0e985ea1117c..736f3bea8b86 100644
--- a/app-crypt/ophcrack/ophcrack-3.7.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.7.0.ebuild
@@ -28,9 +28,9 @@ src_configure() {
myconf="${myconf} $(use_enable debug) --disable-gui"
- econf ${myconf} || die "Failed to compile"
+ econf ${myconf}
}
src_install() {
- emake install DESTDIR="${D}" || die "Installation failed."
+ emake install DESTDIR="${D}"
}
diff --git a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
index 47dd63963818..98ebe5ffe25f 100644
--- a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
@@ -31,11 +31,11 @@ src_configure() {
myconf="$(use_enable debug)"
myconf="${myconf} $(use_enable qt5 gui)"
- econf ${myconf} || die "Failed to compile"
+ econf ${myconf}
}
src_install() {
- emake install DESTDIR="${D}" || die "Installation failed."
+ emake install DESTDIR="${D}"
cd "${S}"
newicon src/gui/pixmaps/os.xpm ophcrack.xpm