summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2020-05-10 12:04:29 +0100
committerMike Auty <ikelos@gentoo.org>2020-05-10 12:04:29 +0100
commitc0b57206a2d619d2c930643397bdb8718786ade8 (patch)
treef5be99821dc42952c0d669cd502bcf0a0264c4bc /app-crypt/ophcrack
parentsys-libs/timezone-data: rollover keywords (diff)
downloadgentoo-c0b57206a2d619d2c930643397bdb8718786ade8.tar.gz
gentoo-c0b57206a2d619d2c930643397bdb8718786ade8.tar.bz2
gentoo-c0b57206a2d619d2c930643397bdb8718786ade8.zip
app-crypt/ophcrack: Fix issue 722030 (AR variable)
Also clears out old versions. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mike Auty <ikelos@gentoo.org>
Diffstat (limited to 'app-crypt/ophcrack')
-rw-r--r--app-crypt/ophcrack/Manifest2
-rw-r--r--app-crypt/ophcrack/files/ophcrack-ar.patch13
-rw-r--r--app-crypt/ophcrack/files/ophcrack-openssl-des.patch92
-rw-r--r--app-crypt/ophcrack/ophcrack-3.6.0.ebuild38
-rw-r--r--app-crypt/ophcrack/ophcrack-3.7.0.ebuild36
-rw-r--r--app-crypt/ophcrack/ophcrack-3.8.0.ebuild17
6 files changed, 22 insertions, 176 deletions
diff --git a/app-crypt/ophcrack/Manifest b/app-crypt/ophcrack/Manifest
index 823ea2bfcb15..aa3a0de8f66a 100644
--- a/app-crypt/ophcrack/Manifest
+++ b/app-crypt/ophcrack/Manifest
@@ -1,3 +1 @@
-DIST ophcrack-3.6.0.tar.bz2 288830 BLAKE2B bc2782d08cb84df24b745fdf0e9723e058da614b73a8d25dfe77cfa2ce291eaf8abd83006a9a410f80bdd240eb81fc402d6d5ebd1c9b92b5a7f1785a203c0c7a SHA512 caa9090b622acac1114f5635c2c58a2c32453ae21a96fc4f424cbc197b056872c282cf9d41142e316a1ffbc9523832b8bc7355c1503c15ac8579470de407a5c9
-DIST ophcrack-3.7.0.tar.bz2 294045 BLAKE2B f506d29b27b4b90eadfd4d650512aea54db4228c4c63b90827a7957b544ab59dae757fc521fe62ab3be55d97e483ddde2aea9ad08c96b77d156e863a61f26312 SHA512 27e73979ca3d733629b9b34c490488cc27140efb8b90d266f270c0b95572cf40319a3fb658c02448fc7a3b825cf05c18a69f5d91bd0656d8410a30645f8dc8c6
DIST ophcrack-3.8.0.tar.bz2 293033 BLAKE2B f20bf79d5cafffaab0667b073e8d9dbcfbae0a16f4139b6304c3f6fc80a24f6ca673db9cd53e28ff277ec35821539f3960265aa28467795e25c45049acca3f31 SHA512 c66276b72299744d3e0c9fc14220c7f568e383bd324c1ede228bda5d51da78db817388421c9f5f8cd2f18687e7e53cfb0c65bcc0354b3d55ac16324c61f62dbd
diff --git a/app-crypt/ophcrack/files/ophcrack-ar.patch b/app-crypt/ophcrack/files/ophcrack-ar.patch
new file mode 100644
index 000000000000..422c17398d20
--- /dev/null
+++ b/app-crypt/ophcrack/files/ophcrack-ar.patch
@@ -0,0 +1,13 @@
+diff --git a/src/common.mk.in b/src/common.mk.in
+index 0f090a8..9c133e0 100644
+--- a/src/common.mk.in
++++ b/src/common.mk.in
+@@ -32,7 +32,7 @@ OBJECTS = $(SOURCES:%.c=%.o)
+ all:
+
+ %.a:
+- ar r $@ $^
++ $(AR) r $@ $^
+ $(RANLIB) $@
+
+ %.o: %.c
diff --git a/app-crypt/ophcrack/files/ophcrack-openssl-des.patch b/app-crypt/ophcrack/files/ophcrack-openssl-des.patch
deleted file mode 100644
index 2515c178abb7..000000000000
--- a/app-crypt/ophcrack/files/ophcrack-openssl-des.patch
+++ /dev/null
@@ -1,92 +0,0 @@
---- a/src/lmtable.c 2013-06-04 07:42:47 UTC
-+++ b/src/lmtable.c
-@@ -470,8 +470,8 @@ void lmtable_mkredux(table_t *tbl, uchar
- /*-------------------------------------------------------------------------*/
- void lmtable_mkhash(uchar_t *pwd, uchar_t *hash) {
- uchar_t key[8];
-- des_key_schedule ks;
-- des_cblock *magic = (des_cblock*)lmmagic;
-+ DES_key_schedule ks;
-+ DES_cblock *magic = (DES_cblock*)lmmagic;
-
- key[0] = pwd[0];
- key[1] = (pwd[0] << 7) | (pwd[1] >> 1);
-@@ -482,7 +482,7 @@ void lmtable_mkhash(uchar_t *pwd, uchar_
- key[6] = (pwd[5] << 2) | (pwd[6] >> 6);
- key[7] = (pwd[6] << 1) ;
-
-- des_set_odd_parity(&key);
-- des_set_key(&key, ks);
-- des_ecb_encrypt(magic, (des_cblock*)hash, ks, DES_ENCRYPT);
-+ DES_set_odd_parity(&key);
-+ DES_set_key(&key, &ks);
-+ DES_ecb_encrypt(magic, (DES_cblock*)hash, &ks, DES_ENCRYPT);
- }
-
---- a/src/samdump2/samdump2.c 2015-03-30 02:26:33 UTC
-+++ b/src/samdump2/samdump2.c
-@@ -71,7 +71,7 @@ void str_to_key(unsigned char *str,unsig
- for (i=0;i<8;i++) {
- key[i] = (key[i]<<1);
- }
-- des_set_odd_parity((des_cblock *)key);
-+ DES_set_odd_parity((DES_cblock *)key);
- }
-
- /*
-@@ -209,8 +209,8 @@ unsigned char* utf16_to_utf8 (unsigned c
- unsigned char hbootkey[0x20];
-
- /* Des */
-- des_key_schedule ks1, ks2;
-- des_cblock deskey1, deskey2;
-+ DES_key_schedule ks1, ks2;
-+ DES_cblock deskey1, deskey2;
-
- int i, j;
-
-@@ -418,15 +418,15 @@ unsigned char* utf16_to_utf8 (unsigned c
-
- /* Get the two decrpt keys. */
- sid_to_key1(rid,(unsigned char *)deskey1);
-- des_set_key_checked((des_cblock *)deskey1,ks1);
-+ DES_set_key_checked((DES_cblock *)deskey1, &ks1);
- sid_to_key2(rid,(unsigned char *)deskey2);
-- des_set_key_unchecked((des_cblock *)deskey2,ks2);
-+ DES_set_key_unchecked((DES_cblock *)deskey2, &ks2);
-
- /* Decrypt the lanman password hash as two 8 byte blocks. */
-- des_ecb_encrypt((des_cblock *)obfkey,
-- (des_cblock *)fb, ks1, DES_DECRYPT);
-- des_ecb_encrypt((des_cblock *)(obfkey + 8),
-- (des_cblock *)&fb[8], ks2, DES_DECRYPT);
-+ DES_ecb_encrypt((DES_cblock *)obfkey,
-+ (DES_cblock *)fb, &ks1, DES_DECRYPT);
-+ DES_ecb_encrypt((DES_cblock *)(obfkey + 8),
-+ (DES_cblock *)&fb[8], &ks2, DES_DECRYPT);
-
-
-
-@@ -471,16 +471,16 @@ unsigned char* utf16_to_utf8 (unsigned c
- if (lm_size != 0x14) {
- /* Get the two decrpt keys. */
- sid_to_key1(rid,(unsigned char *)deskey1);
-- des_set_key((des_cblock *)deskey1,ks1);
-+ DES_set_key((DES_cblock *)deskey1, &ks1);
- sid_to_key2(rid,(unsigned char *)deskey2);
-- des_set_key((des_cblock *)deskey2,ks2);
-+ DES_set_key((DES_cblock *)deskey2, &ks2);
- }
-
- /* Decrypt the NT md4 password hash as two 8 byte blocks. */
-- des_ecb_encrypt((des_cblock *)obfkey,
-- (des_cblock *)fb, ks1, DES_DECRYPT);
-- des_ecb_encrypt((des_cblock *)(obfkey + 8),
-- (des_cblock *)&fb[8], ks2, DES_DECRYPT);
-+ DES_ecb_encrypt((DES_cblock *)obfkey,
-+ (DES_cblock *)fb, &ks1, DES_DECRYPT);
-+ DES_ecb_encrypt((DES_cblock *)(obfkey + 8),
-+ (DES_cblock *)&fb[8], &ks2, DES_DECRYPT);
-
- /* sf27 wrap to sf25 */
- //sf27( obfkey, (int*)&rid, fb );
diff --git a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild b/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
deleted file mode 100644
index 94d9250666bc..000000000000
--- a/app-crypt/ophcrack/ophcrack-3.6.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit eutils
-
-DESCRIPTION="A time-memory-trade-off-cracker"
-HOMEPAGE="http://ophcrack.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug libressl +tables"
-
-CDEPEND="!libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- net-libs/netwib"
-DEPEND="app-arch/unzip
- virtual/pkgconfig
- ${CDEPEND}"
-RDEPEND="tables? ( app-crypt/ophcrack-tables )
- ${CDEPEND}"
-
-PATCHES="${FILESDIR}/ophcrack-openssl-des.patch"
-
-src_configure() {
-
- local myconf
-
- myconf="${myconf} $(use_enable debug) --disable-gui"
-
- econf ${myconf}
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-}
diff --git a/app-crypt/ophcrack/ophcrack-3.7.0.ebuild b/app-crypt/ophcrack/ophcrack-3.7.0.ebuild
deleted file mode 100644
index 736f3bea8b86..000000000000
--- a/app-crypt/ophcrack/ophcrack-3.7.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit eutils
-
-DESCRIPTION="A time-memory-trade-off-cracker"
-HOMEPAGE="http://ophcrack.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug libressl +tables"
-
-CDEPEND="!libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- net-libs/netwib"
-DEPEND="app-arch/unzip
- virtual/pkgconfig
- ${CDEPEND}"
-RDEPEND="tables? ( app-crypt/ophcrack-tables )
- ${CDEPEND}"
-
-src_configure() {
-
- local myconf
-
- myconf="${myconf} $(use_enable debug) --disable-gui"
-
- econf ${myconf}
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-}
diff --git a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
index 98ebe5ffe25f..c35c0f3c154c 100644
--- a/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
+++ b/app-crypt/ophcrack/ophcrack-3.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -14,15 +14,16 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug libressl qt5 +tables"
CDEPEND="!libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- net-libs/netwib
- qt5? ( dev-qt/qtcharts:5
- dev-qt/qtgui:5 )"
+ libressl? ( dev-libs/libressl:0= )
+ net-libs/netwib
+ qt5? ( dev-qt/qtcharts:5
+ dev-qt/qtgui:5 )"
DEPEND="app-arch/unzip
- virtual/pkgconfig
- ${CDEPEND}"
+ virtual/pkgconfig
+ ${CDEPEND}"
RDEPEND="tables? ( app-crypt/ophcrack-tables )
- ${CDEPEND}"
+ ${CDEPEND}"
+PATCHES=("${FILESDIR}/ophcrack-ar.patch")
src_configure() {