summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-26 23:07:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-26 23:15:20 +0200
commitc9e35a606a1e8e7514e18f7c478a4e098f8d8b64 (patch)
tree24f699f9650a990203203b88368ccc7eb30e5e25 /app-crypt/qca
parentwww-plugins/chrome-binary-plugins: automated update (68.0.3438.3) (diff)
downloadgentoo-c9e35a606a1e8e7514e18f7c478a4e098f8d8b64.tar.gz
gentoo-c9e35a606a1e8e7514e18f7c478a4e098f8d8b64.tar.bz2
gentoo-c9e35a606a1e8e7514e18f7c478a4e098f8d8b64.zip
app-crypt/qca: Drop old Qt4-based
Dropping arches without remaining revdeps. Bug: https://bugs.gentoo.org/627178 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/qca-2.1.3-r1.ebuild122
1 files changed, 0 insertions, 122 deletions
diff --git a/app-crypt/qca/qca-2.1.3-r1.ebuild b/app-crypt/qca/qca-2.1.3-r1.ebuild
deleted file mode 100644
index f70ee907f5f6..000000000000
--- a/app-crypt/qca/qca-2.1.3-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils multibuild qmake-utils
-
-DESCRIPTION="Qt Cryptographic Architecture (QCA)"
-HOMEPAGE="https://userbase.kde.org/QCA"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-
-IUSE="botan debug doc examples gcrypt gpg libressl logger nss pkcs11 qt4 +qt5 sasl softstore +ssl test"
-REQUIRED_USE="|| ( qt4 qt5 )"
-
-RDEPEND="
- !app-crypt/qca-cyrus-sasl
- !app-crypt/qca-gnupg
- !app-crypt/qca-logger
- !app-crypt/qca-ossl
- !app-crypt/qca-pkcs11
- botan? ( dev-libs/botan:0 )
- gcrypt? ( dev-libs/libgcrypt:= )
- gpg? ( app-crypt/gnupg )
- nss? ( dev-libs/nss )
- pkcs11? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- dev-libs/pkcs11-helper
- )
- qt4? ( >=dev-qt/qtcore-4.8.7-r2:4 )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtconcurrent:5
- dev-qt/qtnetwork:5
- )
- sasl? ( dev-libs/cyrus-sasl:2 )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1:0= )
- libressl? ( dev-libs/libressl:= )
- )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? (
- qt4? ( dev-qt/qttest:4 )
- qt5? ( dev-qt/qttest:5 )
- )
-"
-
-DOCS=( README TODO )
-
-PATCHES=(
- "${FILESDIR}/${PN}-disable-pgp-test.patch"
- "${FILESDIR}/${P}-c++11.patch"
-)
-
-qca_plugin_use() {
- echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
-}
-
-pkg_setup() {
- MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
-}
-
-src_configure() {
- myconfigure() {
- local mycmakeargs=(
- -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(${MULTIBUILD_VARIANT}_get_mkspecsdir)/features"
- -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(${MULTIBUILD_VARIANT}_get_plugindir)"
- $(qca_plugin_use botan)
- $(qca_plugin_use gcrypt)
- $(qca_plugin_use gpg gnupg)
- $(qca_plugin_use logger)
- $(qca_plugin_use nss)
- $(qca_plugin_use pkcs11)
- $(qca_plugin_use sasl cyrus-sasl)
- $(qca_plugin_use softstore)
- $(qca_plugin_use ssl ossl)
- -DBUILD_TESTS=$(usex test)
- )
-
- if [[ ${MULTIBUILD_VARIANT} == qt4 ]]; then
- mycmakeargs+=(-DQT4_BUILD=ON)
- fi
-
- cmake-utils_src_configure
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_test() {
- mytest() {
- local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
- cmake-utils_src_test
- }
-
- multibuild_foreach_variant mytest
-}
-
-src_install() {
- multibuild_foreach_variant cmake-utils_src_install
-
- if use doc; then
- pushd "${BUILD_DIR}" >/dev/null || die
- doxygen Doxyfile.in || die
- dodoc -r apidocs/html
- popd >/dev/null || die
- fi
-
- if use examples; then
- dodoc -r "${S}"/examples
- fi
-}