summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/shishi/shishi-1.0.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/shishi/shishi-1.0.1-r2.ebuild')
-rw-r--r--app-crypt/shishi/shishi-1.0.1-r2.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-crypt/shishi/shishi-1.0.1-r2.ebuild b/app-crypt/shishi/shishi-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..390d48d987d4
--- /dev/null
+++ b/app-crypt/shishi/shishi-1.0.1-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A free implementation of the Kerberos 5 network security system"
+HOMEPAGE="https://www.gnu.org/software/shishi/"
+SRC_URI="mirror://gnu/shishi/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnutls idn ipv6 nls pam +des +3des +aes +md +null +arcfour static-libs"
+
+DEPEND="gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ dev-libs/libtasn1
+ dev-libs/libgcrypt:0
+ dev-libs/libgpg-error
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix finding libresolv.so
+ epatch "${FILESDIR}/${PN}_resolv.patch"
+ # fix building with automake-1.12 bug #424095
+ epatch "${FILESDIR}/${PN}_automake-1.12.patch"
+ # fix building with glibc-2.16.0
+ epatch "${FILESDIR}/${PN}_gets.patch"
+
+ # don't create a new database
+ sed -i -e '/install-data-hook/s/^/#/' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DMAX_ERROR_DESCRIPTION_SIZE=ASN1_MAX_ERROR_DESCRIPTION_SIZE
+ econf \
+ $(use_enable pam) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_with idn libidn-prefix) \
+ $(use_enable gnutls starttls) \
+ $(use_enable des) \
+ $(use_enable 3des) \
+ $(use_enable aes) \
+ $(use_enable md) \
+ $(use_enable null) \
+ $(use_enable arcfour) \
+ $(use_enable static-libs static) \
+ --with-system-asn1 \
+ --with-libgcrypt \
+ --with-html-dir=/usr/share/doc/${P} \
+ --with-db-dir=/var/shishi \
+ --with-pam-dir=/$(get_libdir)/security \
+ --disable-rpath \
+ --with-packager="Gentoo" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ keepdir /var/shishi
+ fperms 0700 /var/shishi
+ echo "db file /var/shishi" >> "${D}/etc/shishi/shisa.conf" || die
+
+ newinitd "${FILESDIR}/shishid.init" shishid
+ newconfd "${FILESDIR}/shishid.confd" shishid
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ doman doc/man/* doc/*.1
+ dohtml doc/reference/html/*
+ doinfo doc/*.info*
+
+ rm -f "${D}/$(get_libdir)/security/pam_shishi.la"
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+}