summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/simple-tpm-pk11
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/simple-tpm-pk11')
-rw-r--r--app-crypt/simple-tpm-pk11/Manifest1
-rw-r--r--app-crypt/simple-tpm-pk11/metadata.xml11
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.03.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/simple-tpm-pk11/Manifest b/app-crypt/simple-tpm-pk11/Manifest
new file mode 100644
index 000000000000..64a81b128352
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/Manifest
@@ -0,0 +1 @@
+DIST simple-tpm-pk11-0.03.tar.gz 25238 SHA256 0059064cb29900f0db8ce6163ef6aee17b2dcd095613c813dd53ad7f597bf141 SHA512 ed8a1d605bb21ae6abec426f32159882fef74ee7cbc7cdfa5b649a9947f10bad2b95354b2445f3f40dbd9d55803f9fc40fca02605d466e995083c7e9ca29bd8e WHIRLPOOL 1887c7d18a333319a99b28157f7d9b3bce83868154cd3496b8aec911d3d61b13678d0a0ceb143c65cb8addf625e68ccb4008d65af55f87b2bff27d0ac6dddd40
diff --git a/app-crypt/simple-tpm-pk11/metadata.xml b/app-crypt/simple-tpm-pk11/metadata.xml
new file mode 100644
index 000000000000..1ce8da6c4fe9
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>perfinion@gentoo.org</email>
+ </maintainer>
+ <longdescription>A simple library for using the TPM chip to secure SSH keys</longdescription>
+ <upstream>
+ <remote-id type="github">ThomasHabets/simple-tpm-pk11</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.03.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.03.ebuild
new file mode 100644
index 000000000000..f54a2558b7ea
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.03.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE=""
+
+DEPEND="app-crypt/tpm-tools[pkcs11]
+ dev-libs/opencryptoki[tpm]
+ app-crypt/trousers
+ dev-libs/openssl:0="
+RDEPEND="${DEPEND}
+ net-misc/openssh[-X509]"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}