summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/tpm-emulator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/tpm-emulator')
-rw-r--r--app-crypt/tpm-emulator/Manifest1
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator.confd-0.7.42
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator.initd54
-rwxr-xr-xapp-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.460
-rw-r--r--app-crypt/tpm-emulator/files/tpm-emulator.udev1
-rw-r--r--app-crypt/tpm-emulator/metadata.xml8
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild69
7 files changed, 195 insertions, 0 deletions
diff --git a/app-crypt/tpm-emulator/Manifest b/app-crypt/tpm-emulator/Manifest
new file mode 100644
index 000000000000..b1ba89c2c02e
--- /dev/null
+++ b/app-crypt/tpm-emulator/Manifest
@@ -0,0 +1 @@
+DIST tpm_emulator-0.7.4.tar.gz 214145 SHA256 4e48ea0d83dd9441cc1af04ab18cd6c961b9fa54d5cbf2c2feee038988dea459 SHA512 4928b5b82f57645be9408362706ff2c4d9baa635b21b0d41b1c82930e8c60a759b1ea4fa74d7e6c7cae1b7692d006aa5cb72df0c3b88bf049779aa2b566f9d35 WHIRLPOOL c75d49e834f8df6c810d7cb7ca3553e742fde0fd6050af7f7aeda8bbdf652084dda6600719eb0b816e1d51bbc5d9f0e119ea40ce3e59af05fd8d55971056fd6f
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.confd-0.7.4 b/app-crypt/tpm-emulator/files/tpm-emulator.confd-0.7.4
new file mode 100644
index 000000000000..da24e57840b9
--- /dev/null
+++ b/app-crypt/tpm-emulator/files/tpm-emulator.confd-0.7.4
@@ -0,0 +1,2 @@
+STARTUP_MODE="save"
+#DEBUG="true"
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.initd b/app-crypt/tpm-emulator/files/tpm-emulator.initd
new file mode 100644
index 000000000000..7be11767c60e
--- /dev/null
+++ b/app-crypt/tpm-emulator/files/tpm-emulator.initd
@@ -0,0 +1,54 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+opts="save clear deactivated"
+
+STARTUP_MODE='save';
+
+
+depend() {
+ use logger
+ after coldplug
+}
+
+checkconfig() {
+ lsmod | grep -q "^tpmd_dev\b" \
+ || modprobe tpmd_dev &>/dev/null \
+ || eerror "Failed to load module tpmd_dev";
+
+ if [ ! -c /dev/tpm ] && [ ! -c /dev/tpm0 ] ; then
+ eerror "No TPM device found!"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ ebegin "Starting tpm-emulator daemon with mode '$STARTUP_MODE' (tpmd)"
+ checkconfig || eend $?
+ start-stop-daemon --start --chuid tss --exec /usr/sbin/tpmd $STARTUP_MODE > /dev/null
+ eend $?
+}
+
+save() {
+ STARTUP_MODE='save';
+ svc_restart
+}
+
+clear() {
+ STARTUP_MODE='clear';
+ svc_restart
+}
+
+deactivated() {
+ STARTUP_MODE='deactivated';
+ svc_restart
+}
+
+stop() {
+ ebegin "Stopping tpm-emulator daemon (tpmd)"
+ start-stop-daemon --stop --exec /usr/sbin/tpmd --user tss > /dev/null
+ eend $?
+}
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4 b/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4
new file mode 100755
index 000000000000..0ae376ee9f77
--- /dev/null
+++ b/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4
@@ -0,0 +1,60 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+STARTUP_MODE='save';
+
+extra_started_commands="clear save deactivated"
+command="/usr/bin/tpmd"
+command_args="-o tss -g tss"
+
+depend() {
+ use logger
+ after coldplug
+}
+
+checkconfig() {
+ lsmod | grep -q "^tpmd_dev\b" \
+ || modprobe tpmd_dev &>/dev/null \
+ || eerror "Failed to load module tpmd_dev";
+
+ if [ ! -c /dev/tpm ] && [ ! -c /dev/tpm0 ] ; then
+ eerror "No TPM device found!"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ ebegin "Starting tpm-emulator daemon with mode '$STARTUP_MODE' (tpmd)"
+ checkconfig || eend $?
+ checkpath -d -m 0775 -o tss /var/run/tpm
+ start-stop-daemon --start --exec "${command}" -- ${command_args} $STARTUP_MODE > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tpm-emulator daemon (tpmd)"
+ start-stop-daemon --stop --exec "${command}" -- ${command_args} > /dev/null
+ eend $?
+}
+
+clear() {
+ STARTUP_MODE='clear';
+ stop
+ start
+}
+
+save() {
+ STARTUP_MODE='save';
+ stop
+ start
+}
+
+deactivated() {
+ STARTUP_MODE='deactivated';
+ stop
+ start
+}
+
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.udev b/app-crypt/tpm-emulator/files/tpm-emulator.udev
new file mode 100644
index 000000000000..ca053b9d36d3
--- /dev/null
+++ b/app-crypt/tpm-emulator/files/tpm-emulator.udev
@@ -0,0 +1 @@
+KERNEL=="tpm", NAME="%k", SYMLINK+="tpm0", GROUP="tss", MODE="0660"
diff --git a/app-crypt/tpm-emulator/metadata.xml b/app-crypt/tpm-emulator/metadata.xml
new file mode 100644
index 000000000000..276d0e496d12
--- /dev/null
+++ b/app-crypt/tpm-emulator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <upstream>
+ <remote-id type="sourceforge">tpm-emulator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..3b6d47bba1c3
--- /dev/null
+++ b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit user linux-mod cmake-utils udev
+
+MY_P=${P/-/_}
+DESCRIPTION="Emulator driver for tpm"
+HOMEPAGE="http://sourceforge.net/projects/tpm-emulator.berlios/"
+SRC_URI="mirror://sourceforge/tpm-emulator/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ssl modules"
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ !ssl? ( dev-libs/gmp )"
+
+S=${WORKDIR}/${P/-/_}
+
+pkg_setup() {
+ enewuser tss -1 -1 /var/lib/tpm tss
+ if use modules; then
+ CONFIG_CHECK="MODULES"
+ linux-mod_pkg_setup
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNEL_BUILD=${KERNEL_DIR}"
+ fi
+}
+
+src_prepare() {
+ # do not build and install the kernel module
+ sed -i 's/COMMAND ${tpmd_dev_BUILD_CMD}//' tpmd_dev/CMakeLists.txt || die
+ sed -i 's/install(CODE.*//' tpmd_dev/CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_use ssl OPENSSL)
+ )
+ cmake-utils_src_configure
+
+ # only here we have BUILD_DIR
+ MODULE_NAMES="tpmd_dev(misc:${BUILD_DIR}/tpmd_dev/linux)"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use modules && linux-mod_src_compile
+ emake -C "${BUILD_DIR}/tpmd_dev/linux" tpmd_dev.rules
+}
+
+src_install() {
+ cmake-utils_src_install
+ use modules && linux-mod_src_install
+
+ dodoc README
+
+ udev_newrules "${BUILD_DIR}/tpmd_dev/linux/tpmd_dev.rules" 60-tpmd_dev.rules
+
+ newinitd "${FILESDIR}"/${PN}.initd-0.7.4 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-0.7.4 ${PN}
+
+ keepdir /var/log/tpm
+ fowners tss:tss /var/log/tpm
+}