summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-05-31 00:30:55 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2019-05-31 02:46:10 +0300
commit060e20d6da4ac0d03a991ad2f4e2f2ada752c52b (patch)
tree49de7e63857c2674ea7bfa4d98130af99f069c23 /app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
parentapp-crypt/tpm2-tss: version bump (diff)
downloadgentoo-060e20d6da4ac0d03a991ad2f4e2f2ada752c52b.tar.gz
gentoo-060e20d6da4ac0d03a991ad2f4e2f2ada752c52b.tar.bz2
gentoo-060e20d6da4ac0d03a991ad2f4e2f2ada752c52b.zip
app-crypt/tpm2-tools: version bump
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
new file mode 100644
index 000000000000..c9391925f760
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0:=
+ net-misc/curl:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.3-libressl.patch"
+)
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}